Connecting to school proxy

Discussion in 'macOS' started by pjrobertson, Feb 8, 2008.

  1. pjrobertson macrumors 6502a

    Joined:
    Nov 14, 2007
    #1
    So.... here's my problem

    My school is on a proxy (I know the settings - 10.1.1.4 port: 8080 usrname & password) but I can't seem to access it properly.

    After connecting to the network (wireless) I can change Firefox's 'network' settings to have proxy: 10.1.1.4 port: 8080 and this works fine ( I get asked for my username & password in a pop-up box).

    But for stuff like dashboard, software update, adium, etc I can't get it to work.

    I've tried going to the proxies tab in the network settings and ticking all the proxies (tried it with just http web proxy as well), and adding my details, but then when I try to use the programs mention above, they just all crash.

    What do I need to do to get universal access to the internet connection?

    Thanks for your help....
     
  2. Luis macrumors 65816

    Luis

    Joined:
    Jul 19, 2006
    Location:
    Costa Rica
    #2
    Don't you need to change setting in System Preferences instead of Firefox for everything to work?
     
  3. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #3
    You may want to ask the IT department if they have an internal hosted proxy config file. Many networks just have you point the computer to the file which will automatically set all the settings.

    Additionally, you may need to repair permissions. I have heard the screwing with proxy setting in ff on OS X can cause the OS X proxy settings to change mode.

    TEG
     
  4. pjrobertson thread starter macrumors 6502a

    Joined:
    Nov 14, 2007
    #4
    Hmm.... I'll try repairing permissions, but I've had this more than once.

    I'm pretty sure our school doesn't have a proxy config file....

    LOL

    A school of 400; the IT department consists of 1 part-time man (real job = sound technician) and I generally know more than our (note - only one) computer teacher :p

    @Luis - that's what I'm saying, changing proxies in system preferences doesn't do anything (except all the programs trying to use the settings crash)
     
  5. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #5
    It sounds like you tried this, but FWIW...

    I setup a new Network Location called "Automatic + Proxy", which I only use at work, when I'm plugged into the Ethernet.

    I switched to that location and then put my proxy server information into the Socks Proxy tab. The proxy server I use actually runs on my Mac, thus the localhost 9999, but I've used it at other job sites where the proxy server was an official one not hosted by me.
     

    Attached Files:

  6. riscy macrumors 6502a

    riscy

    Joined:
    Jan 4, 2008
    Location:
    China
    #6
    Exactly the same situation here, and it seems that authenticated proxy issues are a known problem with Mac.

    I do not think there is a solution at the minute, maybe 10.5.2 will fix it - if it is not, then I will be seriously annoyed, to say the least.

    If it is any consolation, you can access the applications by unplugging the ethernet cable (disconnect from the web), eg I do that for Journier and other apps that can be used without the web - not perfect, but the best I can suggest for now.
     
  7. pjrobertson thread starter macrumors 6502a

    Joined:
    Nov 14, 2007
    #7
    Thanks everyone for the clarification. I guess it's just another reason to wait for 10.5.2 ....... COME ON!

    @aristobrat (nice name :D)
    I'll try setting up just a SOCKS proxy, but I'm not sure that'll solve my problem.

    A week off school now, so no time to test :( (but :D)
     
  8. pjrobertson thread starter macrumors 6502a

    Joined:
    Nov 14, 2007
    #8
    On a slightly different note.... is there any way to define specific settings for specific wireless networks?

    At home I have a manual IP address and no proxies, but when I go to school I can't use the same IP address (not on the same subnet) and I need a proxy.

    Is there any way to get Max OS X to know that when connected to 'school' (school wireless network) I want it to use DHCP (without manual IP address) and a proxy, then when I connect to my home wireless network it will pick up the old settings; manual IP address and no proxies?

    Let's hope there is, the most annoying thing is having to change the IP address all the time....
     
  9. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #9
    You can setup "Locations" in the networking area, but it requires you to click on Apple > Location and pick the appropriate one when you move around. A lot quicker than having to edit the entire network preferences manually each time.
     
  10. pjrobertson thread starter macrumors 6502a

    Joined:
    Nov 14, 2007
    #10
    Aha! Just what I was looking for aristobrat. :D

    Thanks

    Now I just need to sort out the proxies problem. Here's to hoping it's (ANOTHER) Leopard problem that will be fixed in 10.5.2
     
  11. riscy macrumors 6502a

    riscy

    Joined:
    Jan 4, 2008
    Location:
    China
    #11
    10.5.2 fixed it for me :D

    No proxy problems (ATM), don't want to tempt fate!
     
  12. pjrobertson thread starter macrumors 6502a

    Joined:
    Nov 14, 2007
    #12
    Back to school on Tuesday, I'll let you know.... I hope it's all fixed.
     

Share This Page