Connecting to server with VPN via hostname

Discussion in 'macOS' started by stickyfly19, Apr 11, 2008.

  1. stickyfly19 macrumors newbie

    Joined:
    Mar 11, 2008
    #1
    Hello, I am having trouble connecting to the server with the server name when I connect with VPN. It sounds like a dns issue, however DNS seems to resolve fine when I test it internally. I can connected to it with VPN by using the server address. Any ideas?

    Also, I read somewhere that in OS X 10.5.2 Leopard server that all internal users have to connect to the server by using the .local after the servername then /sharepoint. Can someone clarify this for me. Because my internal users have to type .local to connect. "servername/sharepoint" does not seem to work like it does in tiger. Again it sounds like a DNS, but through terminal and network utility everything seems to resolve. What am i missing? Thanks in advance.

    Cisco ASA, Client running 10.5.2, server running 10.5.2.

    Thanks,
     
  2. dejavont macrumors newbie

    Joined:
    Jun 26, 2008
    #2
    Network Port Configuration order

    I'm under Tiger (10.4.11), so I'm not sure of the workflow under Leopard...

    In System Preferences, under Network, select the Network Port Configuration under the Show: drop-down.

    You'll see your configured ports: eg: Built-In Ethernet, Airport, FireWire, VPN (L2TP)

    Click and drag the VPN (L2TP) list item to the top of the list.

    You're done!

    I don't understand the full reason, but I believe when connected via VPN; any network traffic will hit the Ethernet DNS entries first, then head out your gateway to your ISP's DNS server. By re-ordering the entries, you prioritise the private network DNS first.

    Can someone more knowledgeable clarify?
     
  3. swissmisses macrumors newbie

    Joined:
    Sep 2, 2008
    #3
    VPN Connections May Need IP Address with Server Name

    I'm new to the VPN world, but I discovered that the only way to access my work server remotely through VPN required me to use an IP address in the server address. Note that I needed to do a "ping" through the "Terminal" while at work to obtain the actual server address. (Finder, Utilities, Terminal)

    I'm no expert but it sounds like you are actually connected to the VPN, so I'll skip that part.

    At my work I needed to use a server address when working remotely than I did when I was connected directly to the server at work. So when working remotely I:

    - sign into the VPN connection
    - select "Finder, Go, Connect to Server"
    - type "smb://555.555.55.555/MarketingServer"

    Or put another way, if I normally put "smb://MyWorkServer/MarketingDept" I needed to do put the actual IP address instead of "MyWorkServer". So it needed to look more like this "smb://555..555.55.555/MarketingServer".

    Hope this helps.
     

Share This Page