Connecting to wrong network automaticly

Discussion in 'Mac Basics and Help' started by Ecodisk, Sep 4, 2011.

  1. Ecodisk macrumors member

    Ecodisk

    Joined:
    Mar 8, 2005
    Location:
    Portland, OR
    #1
    I'm using OS X 10.6.8 on a MacBook

    My problem is that my MacBook will automatically connect to my neighbors open network instead of my security enabled network. I can easily just click my own network, and it connects, but I have to do this every time I come home. I also realize that I can go into my network settings and just remove the network from the list, but there is a catch. The network is named "linksys" the default network name for those routers. I connect to other networks with this exact name when I'm not home, so I can't just remove it.

    Is there some kind of way to tell my macbook that my own network is of a higher priority than a linksys network and connect to it whenever it is a available?

    Thanks in advance,
     
  2. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #2
    You can set the priority in System Preferences > Network > Airport, but I'm not sure if you'll see one Linksys entry or multiples. :?
     
  3. Ecodisk thread starter macrumors member

    Ecodisk

    Joined:
    Mar 8, 2005
    Location:
    Portland, OR
    #3
    ah, I see what I missed now. You drag the networks up and down the list to set the priority.
     
  4. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #4
    You could also let your neighbor know that they ought to change their SSID and setup security. They may ask you to help them, but that's what neighbors are for, right?
     
  5. Ecodisk thread starter macrumors member

    Ecodisk

    Joined:
    Mar 8, 2005
    Location:
    Portland, OR
    #5
    I had fixed it for them before when I set up their printer because it benefited both of us, but a week later I found that they had reset their router back to default. So, I just gave up on it. :p
     
  6. killerrobot macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #6
    Why not delete their network from the preferred list so it won't connect to it automatically?
     

Share This Page