Connection failed while logging into Mac App Store -- Anyone?

Discussion in 'Mac OS X Lion (10.7)' started by lyew, Jul 20, 2011.

  1. lyew macrumors newbie

    Feb 2, 2008

    Just a few minutes ago I tried to download OS X Lion through Mac App Store. It prompts me for my Apple ID and password, but after having done this countless times, restarting Mac App Store, updating Snow Leopard, I still keep getting this Connection Failed message. Is anyone experiencing this too? Or is it just me?
  2. Jurko macrumors newbie

    Jul 25, 2011
    I'm having the exactly same problem. I managed to find a couple of "solutions" that worked for some people, but none of them is working for me. This is a serious mindbender for me.
  3. Audiofile macrumors newbie

    Dec 26, 2007
    Same problem with the App Store here.

    I also can download from the iTunes Store. Can't view my account either.
  4. Jurko macrumors newbie

    Jul 25, 2011
    Guys, I've solved the problem. And it's actually pretty simple.

    I've tried couple of things when dealing with this issue. None of them seemed to work. Good thing is that I now know why.

    I've dealt with these questions and conducted mainly the following:
    1. Do you have any cracked apps installed that have been recognized previously by Mac App Store? (e.g. FaceTime)?
    • I've downloaded "MacOSXUpdCombo10.6.7" and extracted the "" from this bundle with Pacifist.
    • Before that, I've deleted Mac App Store with AppZapper by simple deletion.
    • I've also deleted "" from Library/Preferences.
    • Some people at Apple Discussion Forums solved this by repairing permissions of some "Public 3 Class" certificates within KeyChain Access.

    My solution was: "Repairing Little Snitch rule to Mac App Store app" as it was set to "Deny" to any outgoing connections.
  5. Audiofile macrumors newbie

    Dec 26, 2007
    I waited an hour and everything started to work again.

Share This Page