Connection problem in Leopard

Discussion in 'Digital Audio' started by atropos, Oct 27, 2007.

  1. atropos macrumors member

    Joined:
    Jul 26, 2003
    Location:
    Ottawa, ON; Alhambra, CA
    #1
    Hi all:

    Does anyone successful to connect M-Audio Keyboard to Leopard? I plug in my M-AUdio Radium 61 to my MacBook Pro and open garageband; it showed no MIDI connect.. also I can't connect it in AUdio MIDI....:confused: anyone know any way to solve it??
     
  2. fortissimoplaye macrumors newbie

    Joined:
    Oct 29, 2007
    #2
    Midi Keyboard

    Yeah, I've got a Radium 49 and I'm having the same issue. I'm not too hopeful for M-audio to release a new driver soon. They've discontinued this keyboard and haven't even issued a Vista driver.

    I don't know.
    We're in the same boat.
     
  3. nilo macrumors newbie

    Joined:
    May 4, 2005
    #3
    no driver yet

    Same here. Radium 49.

    M-Audio writes: this

    I'm very confident they release a driver for leopard _very_ soon, as the Radium keyboards only need the M-Audio USB Midi drivers, which is a generic driver for a lot of (and also current) M-Audio devices.

    So, lets be a bit patient, I guess in no longer than 2 weeks we have updated drivers. :)
     
  4. h.kon macrumors newbie

    Joined:
    Nov 7, 2007
    #4
    any news?

    Hi!

    I have exactly the same problem with my Radium61 and intel macbook: they don´t communicate, and the driver downloaded from the m-audio website does not make any difference.

    As soon as anone has news on this subject, please post it on the board.

    best regards
    h
     
  5. wirwzd macrumors newbie

    Joined:
    May 20, 2007
    #5
    The driver issue for the Radium49 seems to be with the startup item that loads the driver.
    It is falling prey to a change in Leopard to forking of CoreFoundation processes and errors as follows:

    Code:
    The process has forked and you cannot use this CoreFoundation functionality safely. You MUST exec(). Break on __THE_PROCESS_HAS_FORKED_AND_YOU_CANNOT_USE_THIS_COREFOUNDATION_FUNCTIONALITY___YOU_MUST_EXEC__() to debug. The process has forked and you cannot use this CoreFoundation functionality safely. You MUST exec().
    I did the following and now my Midisport 2.2 and Radium49 booth work in Logic. As alays YMMV and always keep good backups before futzing with the system.

    Code:
    1) Download both the MIDI_USB_OSX_3.2.2 and M-Audio USB MIDI OS X 3.1 
       drivers from M-Audio. I had to select:
          
           Keyboard Series->Radium49->10.4.4 
        
       and check "Show older releases" to download the older drivers
    
    2) Download Pacifist if you don't already have it
    
    3) Install the 3.2.2 drivers and reboot as prompted when finished
    
    4) Navigate to /Library/StartupItems and **BACKUP THE EXISTING "M-Audio
       Firmware Loader" DIRECTORY TO A SAFE LOCATION** 
    
    5) Remove the "M-Audio Firmware Loader" folder from the /Library/StartupItems
       directory.
    
    6) Open the USB MIDI OS X 3.1 install package in Pacifist and drag the 
       "M-Audio Firmware Loader" folder into the /Library/StartupItems directory.     
       Make sure "Use Administrator Privileges" is checked in the dialog window
       after dragging before clicking "Extract"
    
    7) Reboot again
    
    8) Enjoy your Radium49 on Leopard!
    
    Not sure if this works for all devices using these drivers.

    I would also recommend reverting before updating to the new drivers when they come out to avoid any shenanigans.
     
  6. milaszewski macrumors newbie

    Joined:
    Mar 27, 2007
    #6
    The trick worked for M-Audio Transit as well, using M-Audio Firmware Loader from Transit 3.6 installer
     
  7. indirstr8s macrumors newbie

    Joined:
    Oct 14, 2005
    #7
    Milaszewski,

    I am really interested in the fix for the transit as well. Which version did you install first, before replacing the loader.
     
  8. milaszewski macrumors newbie

    Joined:
    Mar 27, 2007
    #8
    Correction: I meant version 1.6, 3.6 doesn't exist :)

    First install 1.6.3 driver, than extract firmware loader from 1.6 and move it to Startup Items, replacing the other one from 1.6.3
     
  9. indirstr8s macrumors newbie

    Joined:
    Oct 14, 2005
    #9
    I had tried this meanwhile and it works :)).
    There are lots of people at various forums looking for a solution.
     
  10. spongeweed macrumors newbie

    Joined:
    Feb 24, 2005
    #10
    I tried reinstalling leopard 10.5 and no luck getting the maudio transit ubs sound card to work. any help would be most appreciated.
     
  11. uitm macrumors newbie

    Joined:
    Jan 5, 2008
    #11
    There are already new packages for Leopard at m-audio.com. While no update for Transit so far, the firmware loader which can be found inside MobilePre software works just fine. Installation hints: 1) install 1.6.3 package for Transit 2) download MobilePre "drivers" for OS X 10.5.1 3) open dmg from #2 4) do "show package contents" 5) copy MobilePreUSBAudio.pax.gz to some place on your hard drive 6) ungzip (gzip -d) this pax file 7) extract the contents with pax -r -v -f MobilePreUSBAudio.pax 8) inside ./Library you'll find the new firmware loader which can be manually copied to /Library, overwriting the older one which came with Transit 1.6.3 package 9) reboot, fix permissions and that's basically all 10) enjoy
     
  12. spongeweed macrumors newbie

    Joined:
    Feb 24, 2005
    #12
    Very nice! It worked & was very easy! Thanks! :)
     
  13. spongeweed macrumors newbie

    Joined:
    Feb 24, 2005

Share This Page