Connection Sharing Issue

Discussion in 'MacBook' started by Droid13, Mar 29, 2010.

  1. Droid13 macrumors regular

    Joined:
    Jul 22, 2009
    Location:
    United Kingdom
    #1
    Dear All,

    I have searched the forum and the Apple support website and haven't been able to get things to work.

    Background:
    My MacBook (May '07, Tiger) is currently connected to the internet via 802.1x ethernet. I would like to use the internet sharing feature to set up a small wi-fi network for my iPhone and my PS3 so that they can get some internet access through the MacBook. It is ok to do this on my current network.

    The Problem:
    I go to the sharing preferences pane and allow connection sharing, as well as personal web access in the firewall settings. I select to share ethernet via airport, name my network and type in a password. Then nothing happens. Airport is on and I cannot see my network on either the iPhone or the PS3.

    I must be doing something wrong here, but can't see what. I am probably being stupid. Please help.

    Regards,
    Droid13
     
  2. BubbaJones macrumors regular

    BubbaJones

    Joined:
    May 13, 2004
    Location:
    East Coast
    #2
    So you have an airport, or are you connecting your Macbook directly to a wired router?

    Nevermind... Mac OS newbie here :eek:

    Try looking here .
     
  3. Droid13 thread starter macrumors regular

    Joined:
    Jul 22, 2009
    Location:
    United Kingdom
    #3
    Sorry, reading my paragraph it is a little muddled. What I am trying to achieve is:

    Wired Connection -> MacBook Ethernet Port -> MacBook Airport -> Ad Hoc Wireless Network -> PS3/iPhone Wireless Connection

    Thanks!
    Droid13
     
  4. GfulDedFan macrumors 65816

    GfulDedFan

    Joined:
    Oct 17, 2007
    Location:
    Indiana
    #4
    Perhaps This Tutorial will help. - GDF

    Or where Bubba said..........
     
  5. BubbaJones macrumors regular

    BubbaJones

    Joined:
    May 13, 2004
    Location:
    East Coast
    #5
    Heh. Once I realized that he meant the airport built into the laptop, I tried to cover up my ignorance by quickly googling the question and updating my post. Guess we both found the same link :p
     
  6. GfulDedFan macrumors 65816

    GfulDedFan

    Joined:
    Oct 17, 2007
    Location:
    Indiana
    #6
    I was going to say... that link wasn't there a minute ago. ;)

    Actually, I've known about MacInstruct for some time. I used their Hard Drive upgrade tutorial in '07. Good stuff.
     
  7. Droid13 thread starter macrumors regular

    Joined:
    Jul 22, 2009
    Location:
    United Kingdom
    #7
    Unresolved, but I've pinpointed the problem!

    Thanks for the link guys - both of you! - while the instructions are basically what I was doing anyway, I decided to switch everything off and follow them word for word, just in case I had done something silly.

    It worked. Briefly. I had a little upwards pointing arrow over my Airport indicator and a network that my iPhone could detect and connect to. All I had to do was connect to the ethernet connection and everything would be great - or so I thought!

    The second I use Internet Connect to connect to 802.1x verified ethernet, I lose my sharing ability. So the problem is to do with the way 802.1x works and the way I connect.

    Any ideas?

    Thanks again!
    Droid13
     
  8. Droid13 thread starter macrumors regular

    Joined:
    Jul 22, 2009
    Location:
    United Kingdom
    #9
    Maybe it is a security thing?

    Thanks for the link - had a look through it, doesn't contain much that I can make use of. Had a look at the 10.4 and 10.6 equivalents as well, just in case there was something in there. No luck.

    I'm thinking this must be some kind of built-in OS X security - you could argue that by using a WEP encrypted Wi-Fi connection to share my secure 802.1x ethernet connection, I am compromising the overall safety of the network - connection sharing bypasses security.

    On the other hand, my friends who have Windows systems have managed this without much hassle. I would like to find the option to allow this and just enable it. Blasted Mac!

    Never mind. There probably is a way of getting this to work, I just can't find it. Grrr...
     
  9. Droid13 thread starter macrumors regular

    Joined:
    Jul 22, 2009
    Location:
    United Kingdom
    #10
    Final (probably) Update

    Done some more intensive searching, this problem seems to have no documented solution. If anyone does know of a way of making this work, please let me know.

    Thanks in advance.

    Regards,
    Droid13
     

Share This Page