Consistently slower Wifi on 3rd gen vs 2nd gen

Donnation

macrumors 6502a
Original poster
Nov 2, 2014
740
695
Since I purchased the 3rd Gen 12.9 iPad Pro, I felt like I wasn't getting the same WiFi speeds as I got with my 2nd Gen 12.9. I thought maybe it was just me thinking that, but I kept seeing it when I'd do basic things like browsing the web and watching videos on YouTube or streaming. The web will stutter and many times YouTube will say no connection for a while or then buffer videos. I have the highest available Spectrum package available in my area, and consistently get around 250 to 300mpbs download and between 20-30mbps upload.

I decided to do some comparisons using the speedtest app. The 3rd gen for whatever reason is lagging behind the 2nd gen every single time. Is anyone else seeing this? I'm not sure what the issue is but my 3rd Gen is definitely getting slower speeds than my 2nd Gen. This doesn't appear to be an anomaly as the 2nd Generation Pro is faster every time than the 3rd Gen.

IMG_1661.jpeg

[doublepost=1541959884][/doublepost]There is definitely an issue here. The 2nd Generation is destroying the 3rd Generation every single time. I just ran them again and its not even close. What the heck is going on here?

IMG_1662.jpeg
 

BeatCrazy

macrumors 68000
Jul 20, 2011
1,808
729
I also (still) have a 10.5” and my 11” that I tested against. No tangible difference in Wi-Fi speeds.

I would guess your 3rd gen is “locked” to the 2.4Ghz radio on your Wi-Fi router. Can you go into your router and check?
 

Donnation

macrumors 6502a
Original poster
Nov 2, 2014
740
695
I also (still) have a 10.5” and my 11” that I tested against. No tangible difference in Wi-Fi speeds.

I would guess your 3rd gen is “locked” to the 2.4Ghz radio on your Wi-Fi router. Can you go into your router and check?
No, that doesn't seem to be it. Its on the 5Ghz band just like the 2nd Gen.
 

a.y.n

macrumors 6502
Jul 7, 2009
264
43
San Francisco
My 11” gets pretty much the same speed as my previous iPads, around 200Mbps, with gig fiber and Eeros. I restored from backup so some of the older results were from my 10.5” and Mini 4.

 

Howard2k

macrumors 68030
Mar 10, 2016
2,558
1,821
Since I purchased the 3rd Gen 12.9 iPad Pro, I felt like I wasn't getting the same WiFi speeds as I got with my 2nd Gen 12.9. I thought maybe it was just me thinking that, but I kept seeing it when I'd do basic things like browsing the web and watching videos on YouTube or streaming. The web will stutter and many times YouTube will say no connection for a while or then buffer videos. I have the highest available Spectrum package available in my area, and consistently get around 250 to 300mpbs download and between 20-30mbps upload.

I decided to do some comparisons using the speedtest app. The 3rd gen for whatever reason is lagging behind the 2nd gen every single time. Is anyone else seeing this? I'm not sure what the issue is but my 3rd Gen is definitely getting slower speeds than my 2nd Gen. This doesn't appear to be an anomaly as the 2nd Generation Pro is faster every time than the 3rd Gen.

View attachment 803301
[doublepost=1541959884][/doublepost]There is definitely an issue here. The 2nd Generation is destroying the 3rd Generation every single time. I just ran them again and its not even close. What the heck is going on here?

View attachment 803302

How close are you to the router, physically? Can you repeat the tests while within 1 foot?
Which router is it?
Separate SSID for 5GHz?
 

mlemonds

macrumors 65816
Apr 9, 2008
1,009
108
Lexington, KY
Hello fellow Lexingtonian! I have had packet loss issues with the qx server before and it looks like you had some drop. Have you tried the metronet server or he Netflix fast app?
 

mattguy10

macrumors 6502a
Aug 18, 2010
587
277
Is there a reason the black levels look bad vs 2nd gen in these pics ?
There’s a “pure black” theme setting in the Speedtest app OP is using and it looks like it’s enabled on the 2nd but not the 3rd gen.

Here’s the iPhone app with and without “pure black”