Console Log Errors

Discussion in 'macOS' started by vixdew, Mar 25, 2010.

  1. vixdew macrumors newbie

    Joined:
    Dec 20, 2008
    #1
    Hi,

    I checked console log, and I keep getting this same error for every application.

    3/25/10 11:08:14 PM Safari[2008] CoreText: Invalid 'kern' Subtable In CTFont <name: LucidaGrande, size: 14.000000, matrix: 0x0>
    CTFontDescriptor <attributes: <CFBasicHash 0x10112bd00 [0x7fff7092cf20]>{type = mutable dict, count = 1,
    entries =>
    2 : <CFString 0x7fff701f8240 [0x7fff7092cf20]>{contents = "NSFontNameAttribute"} = <CFString 0x7fff70913ad0 [0x7fff7092cf20]>{contents = "LucidaGrande"}
    }
    >

    3/25/10 11:07:15 PM System Preferences[2001] CoreText: Invalid 'kern' Subtable In CTFont <name: LucidaGrande, size: 14.000000, matrix: 0x0>
    CTFontDescriptor <attributes: <CFBasicHash 0x200049860 [0x7fff7092cf20]>{type = mutable dict, count = 1,
    entries =>
    2 : <CFString 0x7fff701f8240 [0x7fff7092cf20]>{contents = "NSFontNameAttribute"} = <CFString 0x7fff70913ad0 [0x7fff7092cf20]>{contents = "LucidaGrande"}
    }
    >

    3/25/10 11:07:32 PM Activity Monitor[2004] CoreText: Invalid 'kern' Subtable In CTFont <name: LucidaGrande, size: 11.000000, matrix: 0x0>
    CTFontDescriptor <attributes: <CFBasicHash 0x1001603a0 [0x7fff7092cf20]>{type = mutable dict, count = 1,
    entries =>
    2 : <CFString 0x7fff701f8240 [0x7fff7092cf20]>{contents = "NSFontNameAttribute"} = <CFString 0x7fff70913ad0 [0x7fff7092cf20]>{contents = "LucidaGrande"}
    }
    >

    ..etc


    Anyone know how to fix this?
     
  2. mysterytramp macrumors 65816

    mysterytramp

    Joined:
    Jul 17, 2008
    Location:
    Maryland
    #2
    Sounds like you have a corrupted font.

    Try this:

    1. Open Font Book
    2. Select Lucida Grande
    3. Choose "Validate Font" from File Menu
    The issue you may have is that OS X considers Lucida Grande as "essential" which means your Mac might object if you need to delete the file. You might need a friend to copy the font file for you (it should be at \System\Library\Fonts)

    mt
     
  3. vixdew thread starter macrumors newbie

    Joined:
    Dec 20, 2008
    #3


    Hi!

    Thank you for the response. I have done what you said above and it said no problems were found.

    Review this image http://drp.ly/H5md7+
     
  4. mysterytramp macrumors 65816

    mysterytramp

    Joined:
    Jul 17, 2008
    Location:
    Maryland
    #4
    Are you still getting the same messages in Console?

    Try restarting.

    mt
     

Share This Page