Constant Blank Screen On First Generation iPod Touch

Discussion in 'iPod touch' started by BenEndeem, Oct 30, 2009.

  1. BenEndeem macrumors 6502

    Joined:
    Jul 25, 2008
    Location:
    England
    #1
    The other day I was listening to some music when suddenly the sound and screen cut out completely. I've tried draining the battery and reconnecting to my Mac, but still nothing.

    Strangely though, it still makes the 'new email' and 'syncing' noises, which could perhaps be a good sign, though I'm not getting my hopes up.

    Are there any potential fixes that I should try or has anyone else experienced this? Any advice would be greatly appreciated.
     
  2. WB2Colorado macrumors regular

    WB2Colorado

    Joined:
    Aug 1, 2008
    Location:
    Durango, Colorado
    #2
    I had that problem when my iPod touch was still running 2.2.1 The device would lock up constantly, even after a restore. Haven't had the problem with 3.0, though.

    My fix was doing a force restart by holding the sleep/wake button and the home button until the Apple logo appeared. This would fix it for a little while, at least, if I remember right.
     
  3. BenEndeem thread starter macrumors 6502

    Joined:
    Jul 25, 2008
    Location:
    England
    #3
    Thank you, it seems to have done the trick! Almost bought a new one.
     
  4. WB2Colorado macrumors regular

    WB2Colorado

    Joined:
    Aug 1, 2008
    Location:
    Durango, Colorado
    #4
    Great. I just want to tell you that I never found a way to fix it, though, that problem would always come back for me, even after a restore. Are you still running 2.2.1? Or 3?
     

Share This Page