constant call failed - ios4

Discussion in 'iPhone' started by polobreaka, Aug 9, 2010.

  1. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #1
    anybody ever encounter this annoying issue with ios4 when you keep getting 'call failed' constantly until you either reboot, turn 3g off, turn on and off airplane mode? i am able to receive calls when this happens but its annoying that i have reset everytime when it happens. i notice it happens about the same time after i get off work when i get home. i know i can send and receive text.

    it happened to my roommate as well.

    we are running iphone 3gs under ios4.
     
  2. 184550 Guest

    Joined:
    May 8, 2008
    #2
    I've had this happen with data but not with calls. It's happened maybe two or three times in the last month. On/ Off Airplane mode always fixes it. Also on 3GS with iOS4.
     
  3. polobreaka thread starter macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #3
    mine happens pretty frequent. at least maybe 4 times a week?
     
  4. extraextra macrumors 68000

    extraextra

    Joined:
    Jun 29, 2006
    Location:
    California
    #4
    I have this happen too! On my 3G (running 3.1.2) it happened ALL THE TIME. Like literally every other call. On my iPhone 4 running iOS 4 it happens at least once a day, but not as frequent as every other call.

    It seems to happen most in areas with low signal, but other people on AT&T are still able to make calls and I have to try repeatedly. :confused:
     
  5. polobreaka thread starter macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #5
    strange... my bar shows full while this happens.
     
  6. magicjosh macrumors newbie

    Joined:
    Jun 9, 2010
  7. gottafly macrumors regular

    Joined:
    Aug 26, 2008
    #7
    I had the same problem the other day.

    I thought it may have been related to my Microcell, though.
     
  8. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
  9. Irish Rose macrumors 65816

    Joined:
    May 29, 2010
    #9
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A306 Safari/6531.22.7)

    Maybe not. On the first iP4 that I had, data wouldn't work, even though I had a full 3G signal. Got a new one, and everything works great.
     
  10. Nuttydev macrumors 6502

    Joined:
    Mar 6, 2009
    Location:
    Bristol, England.
    #10
    3G used to do it as well, pretty annoying. Just get call failed instantly, or randomly during a call.
     

    Attached Files:

  11. polobreaka thread starter macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #11
    my phone worked fine when i was at 3.1.2. ever since i ran ios4, this is when it start to happen.
     
  12. mludlow macrumors newbie

    Joined:
    Aug 31, 2010
    #12
    Possible solutions

    I started having this problem every morning when I turned off airplane mode to start my day. One of the following usually fixes this problem

    1. Make sure the Date and Time aren't set "automatically", Manually select your home town, the phone is defaulted to Cupernico and if the phone and your service provider aren't time synced the calls won't work.

    2. Turn airplane mode off/on

    3. Reset Network Settings

    4. Turn on "Show My caller ID"


    Hope these are helpful.
     
  13. Daniel L macrumors 6502

    Joined:
    Sep 15, 2009
    #13
    It only happened when I was in Southern California.
     
  14. mattydee87 macrumors regular

    Joined:
    Aug 22, 2008
    #14
    I got my iPhone 4 yesterday and am in the UK on T-Mobile, got full signal but often I get call failed not long into the call, yet they or I ring back and that call is fine. Very annoying!
     
  15. ItsJustafnPhone macrumors 6502a

    Joined:
    Jul 26, 2010
    #15
    facepalm It's not software

    it's your network, nothing you can do

    turning airplane mode on and off is the best solution to this as it forces your phone to refresh its tower signal
     

Share This Page