constant kernel panics now under 10.5

Discussion in 'macOS' started by BigDaddy5, Nov 10, 2007.

  1. BigDaddy5 macrumors member

    Joined:
    Dec 6, 2006
    #1
    Ive been using 10.5 since release day with almost no issues at all. In fact I rather liked it. However in the last 24 hours I've been getting an obscene amount of kernel panics. I believe its due to the wireless connection. I'm running little snitch, and I can see that I stop recieving incoming data. I'm running mail, firefox, azureus, and adium each time the wireless freezes.

    When I loose the ability to recieve data wirelessly, leopard continues to work fine. But when I try to open network connections, airport, or the wireless menu from the menu bar, or if I try to put my MacBook pro to sleep, I get a nice kernel panic. This sucks.

    I tried searching and all I found was a macbyte that everyone claimed was fud. Unfortunately its not for me. I would really appreciate some help troubleshooting this. I have to post this from my iPhone right now unfortunately...
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Stop running Azeurus for a little while and see if you still get the crashes. :)
     
  3. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
    #3
    I haven't gotten them yet, since an hour after the posting. I didn't change anything, I'm still running azureus, as I was before the panics.

    So far everything is ok. I really don't know what caused it for that day or so. I would estimate at least a half-dozen panics, and I think I'm being conservative.
     
  4. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
    #4
    Well I take it back. I've just had two more kernel panics this morning. Same programs open, same results. I really wish I could figure out why this is.
     
  5. TemeculaMac macrumors regular

    Joined:
    Aug 8, 2007
    #5
    Is there anything in your system logs? You should have some indication of the problem within these logs.

    Gary
     
  6. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
    #6
    Gary,

    Thanks for pointing me in, hopefully, the right direction. I checked into my system logs, and I see a lot of warnings and errors, but nothing that appears to be critical. Lots of debugs too, which is to be expected. I'm not 100% sure what I'm looking for, however, but I don't see anything that jumps out at me either, in the last few hours. I just had another KP, so I should have something recently to indicate a problem.

    Actually, now that I dig a little deeper, I see this:


    Code:
    Mon Nov 12 12:14:42 Macbook [0x0-0x23023].org.gudy.azureus2[214] <Notice>: DEBUG::Mon Nov 12 12:14:42 EST 2007::org.gudy.azureus2.core3.peer.impl.transport.PEPeerTransportProtocol::decodeBitfield::2082:
    Mon Nov 12 12:14:42 Macbook [0x0-0x23023].org.gudy.azureus2[214] <Notice>:   R: 72.172.88.53: 18222 [Azureus 2.5.0.0] has sent invalid Bitfield: too short [0<123]
    Mon Nov 12 12:14:42 Macbook [0x0-0x23023].org.gudy.azureus2[214] <Notice>:     PEPeerTransportProtocol$10::messageReceived::2540,IncomingMessageQueueImpl::receiveFromTransport::134,MultiPeerDownloader::doProcessing::151,ReadController::doRead::293,ReadController::doHighPriorityRead::253,ReadController::readProcessorLoop::218,ReadController::access$200::43,ReadController$2::runSupport::88,AEThread::run::69
    Mon Nov 12 12:15:38 Macbook kernel[0] <Debug>: ath_rxbuf_init: no mbuf/cluster
    Mon Nov 12 12:19:58 Macbook [0x0-0x23023].org.gudy.azureus2[214] <Notice>: Invalid PEX message received: too large [53/-1]R: 67.167.211.136: 56060 [XTorrent [FAKE: "Azureus 2.5.0.4" / "Transmission 0.7-svn"]]
    Mon Nov 12 12:20:02 Macbook kernel[0] <Debug>: ath_rxbuf_init: no mbuf/cluster
    
    I'll check back in my logs later this afternoon to see if that appears after each crash.

    I did some digging up online, and it would appear that this issue might be somewhat related to just maxing out wireless, and not an azureus issue. But if dropping azureus for another torrent program solves the issue, I might do that. I am still concerned, though, that a java-based torrent program can crash my OS.
     
  7. TemeculaMac macrumors regular

    Joined:
    Aug 8, 2007
    #7
    You can typically see a gap in time when your system kernel panics. Check for all messages leading up to this gap to see what was running, or what may have caused the panic.
     
  8. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
    #8
    Yeah, that's what I did. The next line after that block I posted was:
    Mon Nov 12 12:30:49 localhost kernel[0] <Debug>: npvhash=4095

    Which is 10 minutes later. And all subsequent lines indicate a reboot (lots of localhost and kernel records).

    What bothers me about those last lines are that they indicate azureus. The symptoms I'm having don't appear to be directly related to azureus, although that program could be the root cause. What causes the kernel panics are that I loose all incoming internet connections, and when I try to remedy the situation by opening up the menu bar airport, or going into syspref's and opening up the network config, I end up crashing. This would lead me to believe that the direct cause of my crashes are related to airport, but I find nothing in the system.log that would indicate a call to the network items.
     
  9. dukeblue91 macrumors 65816

    dukeblue91

    Joined:
    Oct 7, 2004
    Location:
    Raleigh, NC
    #9
    Your logs are really just pointing to Azureus so I would turn that off, repair permissions and do a reboot.
    Leave Azureus off for a while and see if you still get KP's.
     
  10. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #10
    That message "Invalid PEX message received: too large ..." seems to be related to azereus/transmission transactions. It's possible, perhaps, that a badly formed incoming packet could cause a buffer overflow in airport, causing it to crash and in a domino effect bring down your Mac. Which would be a bug in the OS.

    The next message mentions "ath_rxbuf_init" which would seem to be buffer-related, unless the programmer used a badly chosen name. Searching a bit further, ath_rxbuf_init is a FreeBSD WiFi driver-related function (nothing directly to do with azereus).

    Are the other KPs directly related the same message?

    Edit: the atheros chipset (which uses ath_rxbuf_init) has been found to be related to KPs in the past - http://episteme.arstechnica.com/eve/forums/a/tpc/f/8300945231/m/668007424831/p/1 - perhaps you've just found another way of triggering this.
     
  11. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
    #11
    I browsed back to my first kernel panic this morning, at or around 7-8am. I found a bunch of errors with this error message:

    Code:
    Mon Nov 12 07:18:09 Macbook [0x0-0x1f01f].org.gudy.azureus2[192] <Notice>:   R: 72.172.88.53: 25076 [Azureus 2.5.0.0] has sent invalid Bitfield: too short [0<123]
    
    . There were many other IP's and ports as well. I would say maybe a dozen or so lines like this.

    Next are about a half dozen lines like this:
    Code:
    Mon Nov 12 07:25:11 Macbook mDNSResponder[15] <Error>: uDNS_CheckCurrentQuestion no DNS server for lb._dns-sd._udp.0.55.211.10.in-addr.arpa. (PTR)
    
    The next few lines are just notices at 7:36, and then nothing until 10:38.

    Looks like I rebooted about 5 minutes later:
    Code:
    Mon Nov 12 10:44:05 Macbook [0x0-0x1f01f].org.gudy.azureus2[192] <Notice>: \tat org.gudy.azureus2.core3.util.AEThread.run(AEThread.java:69)
    Mon Nov 12 11:18:19 Macbook kernel[0] <Debug>: IOResources: match category DigiIO exists
    Mon Nov 12 11:18:19 Macbook kernel[0] <Debug>: IOResources: match category DigiIO exists
    Mon Nov 12 11:19:03 Macbook VLC[242] <Warning>: applicationWillTerminate
    Mon Nov 12 11:19:11 Macbook ReportCrash[618] <Warning>: unable to read PC for current frame pointer;  truncating stack
    Mon Nov 12 11:19:11 Macbook ReportCrash[618] <Notice>: Formulating crash report for process VLC[242]
    
    Again at 11:49 I got a bunch of those bitfield too short messages, but it doesn't look like I crashed until 12:20.

    I know I saw kernel panic's three times today, but I'm having problems isolating the third one from this log. I'll keep looking and see what I find. I don't see anything like I found in my previous post, though.

    Edit: I did a quick search for ath_rxbuf_init and found probably a dozen or more instances of the mbuf/cluster error in my log, which goes back until the noon on the 11th, but I didn't have any problems until this morning with kp's.
     
  12. dr_lha macrumors 68000

    Joined:
    Oct 8, 2003
    #12
    Your kernel panics are caused by using Azureus. Stop using it and your kernel panics will stop.
     
  13. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
    #13
    I'm sorry, dr_lha, but I don't think that's an acceptable solution. Right now, of course I will but one of the reasons that I switched to OS X is because programs aren't supposed to interact at the kernel level of the OS. If Azureus is really causing the kp's, then apple needs to tighten up their kernel.

    But until then, I would like to determine exactly how Azureus is causing my kp's so I can then determine if other torrent programs will do the same or if this is just a one-program flaw in the OS.
     
  14. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #14
    May be a problem with Little Snitch and Azureus on a wired connection.

    Or Azureus and an Airport connection.

    Some people have had luck running Azureus on a ethernet connection with Little Snitch completely disabled.

    Or simply one of the other apps.

    ---

    I doubt Apple will care much that this app does not work.
     
  15. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
  16. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
    #16
    I agree with you, but I do believe that apple should care their OS is crashing because the app doesn't work. If the app just crashed, then I would blow it off. But the fact that it's interfering with my OS is just...well, it brings me back to when I was using Windows. I still have programs in XP that can blue screen it, something I was very happy I didn't have to deal with in OS X. That being said, I have nothing against either OS's, since I obviously use both.
     
  17. dr_lha macrumors 68000

    Joined:
    Oct 8, 2003
    #17
    I wasn't suggesting stopping using Azureus forever, just for now until Apple fixes the networking issue that causes the kernel panics. Clearly an application shouldn't be causing such panics.
     
  18. jomams macrumors newbie

    jomams

    Joined:
    Nov 2, 2007
    Location:
    mke and the oc
    #18
    similar situation

    i posted this in a different thread before i found this one:

    -----

    i've had noooo issues with leopard since installing the week after it debuted. now i've had 3 kernel panics in 4 hours - one while i was typing up this post - and i wasn't even doing anything intensive. during panic number 2 i was also idle for a good 10 min.

    like i said, nothing intensive. adium, a torrent app, and firefox. the first panic occurred was while i was reinstalling firefox.

    only other odd behavior was last night when i put my mbp to sleep with 100% juice. i came back a couple hours later to find it HOT - hotter than i've ever felt it - and with a drained battery.

    santa rosa 2.4 duo mbp

    ----

    so i switched around - safari instead of firefox, no adium - seemed to come down to azureus only. the network would drop and then if i clicked on either the airport dropdown or in sys prefs chose network it would kp immediately. otherwise just let it sit for a few and it'd do it on its own.
     
  19. DerChef macrumors 6502

    DerChef

    Joined:
    Apr 29, 2005
    Location:
    Northern Ireland
    #19
    A few days into my leopard upgrade I was getting freezing and kernel panics at about 2 a day.

    Was about to dual boot back to tiger and wait for 10.1 or 10.2

    Then I got shot of quicksilver (new spotlight is as good) and updated growl to 1.1.2.

    Now the system is rock solid ;) no crashes in over a week even running C23, safari, mail and a time machine backup all at once :eek:

    I cant give you definitive proof that is was one of these pair that was causing the bother but it looks very suspicious
     
  20. iKwick7 macrumors 65816

    iKwick7

    Joined:
    Dec 29, 2004
    Location:
    The Wood of Spots, NJ
    #20
    While I haven't had any kernel panics, I have had nothing but problems since switching to Leopard. iMovie is totally unuseable, iTunes crashes all the time, and I get the occasional system freeze. I think I am switching back to Tiger. And I did a clean install, too. Grrrr.
     
  21. whippet macrumors newbie

    Joined:
    Jun 22, 2007
    Location:
    sydney australia
    #21
    kernel panics

    since replacing my 2x 512 ram with 2x1gig i have had no more panics. suffered with them 2 or 3 times a day if not more. reports never told me anything I could understand. apple couldnt find a problem. so finally went on line, double my ram $99 each and end of problems! imac G5 20" 1.8 power PC
     
  22. whippet macrumors newbie

    Joined:
    Jun 22, 2007
    Location:
    sydney australia
    #22
    kernel panics

    should also add that time machine worked for the first time ever. full back up in about an hour
     
  23. Devil's Refugee macrumors 6502

    Joined:
    May 14, 2007
    #23
    I've stopped using Azureus and started using Transmission until they can find a fix
     
  24. northernmunky macrumors 6502a

    northernmunky

    Joined:
    Jan 19, 2007
    Location:
    London, Taipei
    #24
    I've had similar problems with Wireless connections stalling after a certain amount of time... searching through other forums I've traced the problem down to compatibility with Leopard and certain Wireless-n routers... possibly draft-n models (I'm using a Linksys WRT300N) which seems to cause the mouse to intermittently freeze for a second as well which others have reported.

    I've only had two kernel panics so far (first ones I've seen in a very long time!)... one of which when my SR Macbook Pro was sat idle for an hour while I was out of the house... only major program running was Transmission. :(

    Aside from that a heck of a lot of reboots when it starts misbehaving.... bring on 10.5.2!!!
     
  25. shadowmoses macrumors 68000

    shadowmoses

    Joined:
    Mar 6, 2005
    #25
    I am pretty sure Transmission is causing me daily Kernel panics since 10.5.1 there is definitely a problem with networking somewhere.

    See log below:

    Tue Dec 4 14:40:27 2007
    panic(cpu 0 caller 0x0039CD77): "m_free: freeing an already freed mbuf"@/SourceCache/xnu/xnu-1228.0.2/bsd/kern/uipc_mbuf.c:2742
    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x3407f708 : 0x12b0e1 (0x455670 0x3407f73c 0x133238 0x0)
    0x3407f758 : 0x39cd77 (0x48e03c 0x1 0x3432701c 0x3407f7c4)
    0x3407f798 : 0x39d073 (0x302b2100 0x0 0x52dc110c 0x52dca710)
    0x3407f7b8 : 0x9db821 (0x302b2100 0x0 0x20 0x0)
    0x3407f8e8 : 0x9e49e5 (0x1 0x0 0x52dbe930 0x52dca78c)
    0x3407fc08 : 0x9e993a (0x23b152c8 0x0 0xffffffff 0x7fffffff)
    0x3407fde8 : 0x9eafb1 (0x23b152c8 0x6b86e5c 0x3407fe38 0x136870)
    0x3407ff18 : 0x41d149 (0x23b15000 0x42c3a00 0x1 0x19ccc1)
    0x3407ff68 : 0x41c2a6 (0x42c3a00 0x6b0e8b8 0x3407ffc8 0x3da847)
    0x3407ff98 : 0x41bf88 (0x42d8ac0 0x5049a8 0x44ac2e0 0x0)
    0x3407ffc8 : 0x19e2ec (0x42d8ac0 0x0 0x1a10b5 0x44b5c80)
    Backtrace terminated-invalid frame pointer 0
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.driver.AirPort.Atheros(300.22)@0x9b6000->0xa40fff
    dependency: com.apple.iokit.IO80211Family(200.7)@0x998000
    dependency: com.apple.iokit.IOPCIFamily(2.4)@0x63c000
    dependency: com.apple.iokit.IONetworkingFamily(1.6.0)@0x64c000

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9B18

    Kernel version:
    Darwin Kernel Version 9.1.0: Wed Oct 31 17:46:22 PDT 2007; root:xnu-1228.0.2~1/RELEASE_I386
    System model name: MacBook1,1 (Mac-F4208CC8)
     

Share This Page