Constant mds activity

Discussion in 'macOS' started by SebZen, Feb 19, 2010.

  1. SebZen macrumors 6502

    Apr 12, 2009
    Please help me with this. I'm afraid it will break my hard drive soon!

    Ever since I ran Onyx last week, mds keeps reading from my harddrive at about 2mb/second.

    For example I've only had my computer open for a couple of hours and done very little, just some browsing, and Activity Monitor shows 7.52GB read and 6.44GB written...

    What the heck is going on?? How can I stop this? I tried re-running Onyx and it did not help.
  2. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    What Mac and what Mac OS X version do you use, what kind of scripts did you let Onyx run?
    Do you have any additional hardware connected to your Mac?

    Have you tried adding specific folders/volumes that are under constant access and change to your Privacy list in the Spotlight preferences?


  3. angelwatt Moderator emeritus


    Aug 16, 2005
    The mds process is Spotlight, which is what I think spinnerlys was trying to say. It's doing indexing. Mine does the same thing from time-to-time. This topic has come up a few times. You can see this thread and hit up MRoogle to find others.
  4. SebZen thread starter macrumors 6502

    Apr 12, 2009
    Problem is it isn't from time to time. It's constant! It does not stop.

    I've ran every Onyx script (but did not check anything that was not checked before).

    I've done this before already and it hasn't done any harm. But for some reason when I downloaded again last week, it started the mds thing.

    I didn't do anything with Spotlight in the privacy option.

    And I am running 10.6.2 on mid 09 MBP
  5. SebZen thread starter macrumors 6502

    Apr 12, 2009
    Odd, I just added my HD to the privacy options and mds is still going

    edit: Nevermind, took about 30 seconds. It stopped now.

    So what am I supposed to do? I've already left the laptop open (without sleep) for a night a few days ago hoping that it would index everything and stop, but it didn't help

Share This Page