constant mdworker errors

Discussion in 'Mac Basics and Help' started by stevelam, Oct 23, 2013.

  1. stevelam macrumors 65816

    Joined:
    Nov 4, 2010
    #1
    I keep getting this in my error console: mdworker: (warning) Import: Bad path:

    [​IMG]

    and i have no idea what it means or how to get rid of it, despite trying to google it.

    can anyone shed light on this? it just keeps going and going.

    Rebooting doesn't get rid of it either. I recently installed Mavericks but as I never usually check console/logs and I don't think it was the installation that brought it on or anything
     
  2. lincoln17 macrumors newbie

    Joined:
    Oct 23, 2013
    #2
    I noticed the same thing. I went to the menu bar and clicked on Spotlight and saw that it was trying (and likely failing) to index an old iPod Shuffle I had recently connected. Once I unmounted the shuffle, the error messages stopped and thing returned back to normal.
     
  3. inarus macrumors newbie

    Joined:
    Oct 25, 2013
    #3
    I'm having the same problem.

    I have already format and reinstall the system and still doing that.


    any help?
     
  4. ssgoku129 macrumors newbie

    Joined:
    Nov 1, 2013
    #4
    ExFAT Partition?

    Hey in my case, it turned out to be my ExFAT partition where I store my dropbox, all I did was exclude the partition from Spotlight indexing in System Preferences and restarted back into Mavericks, no longer getting the error and my machine isn't roaring
     
  5. natiruts macrumors newbie

    Joined:
    Nov 1, 2013
    #5
    I'm having the same problems. For me the problem seemed to have to do with iTunes accessing media on an exFat partition. The partition can be indexed, but if I open iTunes it will start looping the same error message as you've got.

    I've tried all advice on spotlight indexing problems that can be found online and reinstalled mavericks twice, but still the problem prevails, there's only two ways I can stop it, either by unmounting the exFat partition in Disk Utility or by disabling Spotlight with a terminal command

    If you use Spotlight mainly for launching applications a temporary solution is to disable Spotlight and remap the keyboard shortcut to Launchpad.
     
  6. ftslee macrumors newbie

    Joined:
    Nov 17, 2013
    #6
    Same here.

    In my case I am running Maverick with MBA 2013. I have previously inserted an SD card in the card store and use it to serve my Dropbox and Downloads - and when I kept getting that mdworker Bad Path problem I put the whole SD card folder into the privacy tab of Spotlight, but was getting an UNKNOWN error. The system was then became frozen and I couldn't even shut it down.

    I took the "courage" to press the power button for a few seconds and after restart, I was able to put the SD card into Privacy tab and everything has become fine since then.
     
  7. webknows macrumors newbie

    Joined:
    Nov 30, 2010
    Location:
    Sao Paulo, Brazil
    #7
    I have the same scenario and problem, but to make it worst, Spotlight system preferences won't let me add the ExFAT partition to its Privacy list, an unknown error is announced instead. Awesome... but not.
     
  8. webknows macrumors newbie

    Joined:
    Nov 30, 2010
    Location:
    Sao Paulo, Brazil
    #8
    OK, I just had to be quick at typing. Here's how I just managed to disable searching and indexing of the offending volume (ExFAT external hard drive), executing the following commands, on this order, consecutively on my OS X 10.9 (Mavericks):

    Code:
    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
    sudo mdutil -i off /Volumes/<Volume name>
    sudo mdutil -d /Volumes/<Volume name>
    The result was a message "Indexing and searching disabled.", obtaining the result I'd expect.

    This ceased the errors like "25/11/13 12:38:35,869 mdworker[3314]: (Warning) Import: Bad path:" and the mds process stopped trying to index that volume and at the same time, stopped consuming a lot of unnecessary CPU cycles.

    Problem solved for me.
     
  9. Robert Davies macrumors 6502

    Robert Davies

    Joined:
    Jul 28, 2011
    Location:
    People's Republic of Wrexham
    #9
    Thank you!!! :)

    Following your instructions solved it for me too.

    See the search function does work!
     
  10. Bonnie H., Feb 1, 2016
    Last edited: Feb 3, 2016

    Bonnie H. macrumors newbie

    Bonnie H.

    Joined:
    Feb 1, 2016
    #10
    --- Post Merged, Feb 1, 2016 ---
    Solved for me. Just be careful to input both lines of code. It's hard to "undo" anything in terminal.
     
  11. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #11
    I am not sure why you need a terminal command to stop indexing on a volume. Can't you just add it to the privacy list in the Spotlight prefs in the System Prefs. I would think that would do the same thing.
     

Share This Page