Constant Safe Mode after 3.1 upgrade

Discussion in 'Jailbreaks and iOS Hacks' started by bored911, Sep 16, 2009.

  1. bored911 macrumors 6502

    bored911

    Joined:
    Feb 18, 2007
    Location:
    NYC
    #1
    So I did a google search and found out that winterboard was probably causing this problem, and the update to mobile substrate would fix it. Well that came and went with no help, and i'm stuck without winterboard for the moment. Is there anything else that might have caused this?
     
  2. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #2
    Did you try going into cydia in safe mode to see if the update is still there?
     
  3. bored911 thread starter macrumors 6502

    bored911

    Joined:
    Feb 18, 2007
    Location:
    NYC
    #3
    Yeah, 0.9.3043-1, confirmed as the newest with saurik's twitter updates. Tried reinstalling both that and winterboard, with no luck.
     
  4. enzom21 macrumors 6502

    Joined:
    Nov 2, 2008
    #4
    Do you have weathericon installed? That was causing safe mode for me.
     
  5. bored911 thread starter macrumors 6502

    bored911

    Joined:
    Feb 18, 2007
    Location:
    NYC
    #5
    Nope, but i just compiled a list of things dependant on mobile substrate.

    They are:
    Winterboard
    attachment= for mailto:
    SBSettings
    Backgrounder
    Bosspaper
    Cydelete
    Five Icon Dock
    iPodPop
    gPower
    libhide
    maps enhancer
    PreferenceLoader
    PrivaCy
    StatusNotifier
    Supreme Prefrences 3.0
    Tlert
    VOIPover3G


    WOW, a lot more than I thought. It would take forever to uninstall/reinstall all this, so does anyone know if any of these specifically are causing any problems. If not I guess i'll have to do it by hand but that would be a last resort.
     
  6. polysaturate macrumors member

    Joined:
    Jun 30, 2009
    #6
    Heh...now I see this. I suppose that's what did it for me, though I uninstalled mobilesub and it took all the fun stuff with it...cydelete etc etc. Oh well, live and learn...
     
  7. enzom21 macrumors 6502

    Joined:
    Nov 2, 2008
    #7
    When I reinstalled winterboard I was getting an incompatibility warning about Rock apps so you might want to uninstall rock and tlert.
     
  8. pauliphone macrumors regular

    Joined:
    Nov 27, 2008
    Location:
    London, UK
    #8
    i think its 5 icon dock thats causing the problem, due to being able to arrange the icons on itunes it can't handle it.
     
  9. bored911 thread starter macrumors 6502

    bored911

    Joined:
    Feb 18, 2007
    Location:
    NYC
    #9

    IT WORKED!!! Good call, my iPhone and I greatly appreciate it!
     
  10. squint0241 macrumors member

    Joined:
    May 10, 2008
    #10
    Safe Mode

    I have the latest 3.1 with winterboard and initially I was getting the same symptom "Safe Mode" activated. I restored again and then loaded one Cydia app at at time to try to isolate which one was the menace. Load the primary packages first. Then the nice to have stuff. The bad app for me was the Glasklart Live Clock of which I believe there might be other Live Clock apps out there causing the same prob. It's been about a week now and no safe mode issues. Got the latest Cydia updates which I presume may have helped, i.e, mobilesubstrate and what not. It's all a hit and miss when you make an upgrade early on. The Cydia apps writers have to play catch-up to stabilize and verify that their apps are stable on the new OS (This takes Time!). So for us early OS adopters and jailbreakers...it comes with the turf!:)
     
  11. squint0241 macrumors member

    Joined:
    May 10, 2008
    #11
    I haven't had an issue with the 5 icon deck...FYI. Working fine on 3.1.
     
  12. squint0241 macrumors member

    Joined:
    May 10, 2008
    #12
    Sorry Gents, I meant to say Live Weather App "Not Clock"...
     
  13. squint0241 macrumors member

    Joined:
    May 10, 2008
    #13
    Wouldn't it be nice if everything just worked...lol. Unfortunately on our part, we have to have patience and ingenuity and work to solve our own problems most of the time. Thank god there is a Forum of people like us to troubleshoot and work these things out! Cheers...:)
     

Share This Page