Constant spinning wheels-Unable to discover virtual mem dir's

Discussion in 'macOS' started by mikentosh2003, May 9, 2015.

  1. mikentosh2003 macrumors newbie

    mikentosh2003

    Joined:
    Jun 21, 2007
    Location:
    North SoCal
    #1
    Hi- I've got an '07 17" 2.4ghz Macbook Pro core2duo 4g ram OS 10.8.5

    For some time now, I've been getting spinning wheels all the time. At first I just blamed it on Firefox and me having a ton of tabs open all the time.
    But after switching browsers and cutting down on the number of tabs I let myself have open, I still got the spinners....

    I noticed when I ran 'Applejack' I got what looks like an error message, and I couldnt run 'validate prefs' or clear 'cache files' on my user directory. I usually typed in 'mikemac' and it would do its thing. Now it doesnt recognize it and it shows a bunch of [501] and one [502]

    It also showed this when I couldn't fix the permissions...

    "The domain/default pair of (system/library/launchDaemons/com.apple.dynamic_pager. ProgaramArguments) does not exist
    /var/root/library/scripts/applejack.sh: line 1887: PA: readonly variable
    Unable to discover location of virtual memory directories! <-yellow text
    mke sure $swapdir is declared in a standard way. As a temporary workaround, please enter the correct VM directory location at the prompt. Or jut hit return to accept the default location (/private/var/vm) (enter directory)"

    There's also a couple of other strange error mesages I can see when I watch it boot in verbose mode. I do that a lot just 'cause I find it interesting. But it goes by so quick, its kinda hard to catch it exactly.
    But I could see a line- bootcache: boot cache size is large (huge 10+ digit number) larger than the actual size, or something like that...

    Don't know if that is important or not. I figure I could maybe borrow a video camera and video record all the text if need be.

    The missing $swapdir looks suspicious to me, but I don't have a clue really...

    Anyone have any advise for me? I was running os 10.7 when this all started, and updated to 10.8.5 hoping it might fix things. It didn't....Help!

    Thanks for any mac mojo ya might send my way, I'd appreciate it!
    -Mike
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    OP wrote above:
    [[ But I could see a line- bootcache: boot cache size is large (huge 10+ digit number) larger than the actual size, or something like that... ]]

    First, try downloading a small free utility called "Yasu":
    http://yasuapp.net
    It's no longer actively supported, but it still works.
    I believe the version you need for 10.8.5 is 2.9.1
    (download link provided at page above)

    Try running Yasu.
    My suggestion is to check EVERYTHING EXCEPT your browser cookies.
    Yasu will either shut down or restart the Mac when done.
    I suggest "restart".

    See if this helps.
    If it doesn't:

    Can you locate and delete the bootcache file?
    It's only a cache, it will be rebuilt through subsequent bootups.

    Also, try downloading DiskWave:
    http://diskwave.barthe.ph

    It's a small, free utility that will show you where and what size files are on your drive.
     
  3. mikentosh2003 thread starter macrumors newbie

    mikentosh2003

    Joined:
    Jun 21, 2007
    Location:
    North SoCal
    #3
    bootcache too large and Thanks!

    That error I couldn't rememember last time was-
    boot cache: bootcache too large for physical memory (and a large jumber in parenthessis)

    then a bunch of- SMC ReadKeyAction errors....'can't find them' of varying types... SMC yadda yadda can't be found, is no good, sleeps around on its wife, hits its kids etc...goes bye too quick though! :)

    Downloaded those apps and will give them a try now. thanks again. I'll post whatever luck I have. Good or bad.

    Mike
     

Share This Page