Constantly high cpu usage (soagent, callservicesd)

Discussion in 'OS X El Capitan (10.11)' started by ciacorp, Jun 24, 2015.

  1. ciacorp macrumors member

    Joined:
    Feb 17, 2012
    #1
    With both beta 1 and beta 2, I have a permanent high cpu usage due to the processes

    soagent
    callservicesd

    It seems there is problem with contacts syncing, although contacts.app is working properly.

    Anyone having the same problem?
     
  2. dimitrimckay macrumors newbie

    dimitrimckay

    Joined:
    Jun 25, 2015
    Location:
    New York City
    #2
    Same here. soagent which is related to messages is going bananas. Fan is running constant. Haven't found a workaround.
     
  3. ciacorp thread starter macrumors member

    Joined:
    Feb 17, 2012
    #3
  4. jonathanredford macrumors newbie

    Joined:
    Dec 20, 2015
    #4
    Still having these issues with soagent/message - OS X 10.11.2
     
  5. keithferguson2015 macrumors newbie

    keithferguson2015

    Joined:
    Dec 23, 2015
    #5
    As of today i am having these same issues. Both processes have CPU at 66% or higher and i stay around 80% usage. My laptop is crawling and doesnt seem like there is anything i can do about it.
     
  6. keithferguson2015 macrumors newbie

    keithferguson2015

    Joined:
    Dec 23, 2015
  7. ksec macrumors newbie

    Joined:
    Dec 23, 2015
    #7
    Same here, soagent eating up all my CPU, and along with nsurlsessiond bug, My Mac experience has been going downhill for the past 2 years.......
     
  8. Nicolegracia macrumors newbie

    Nicolegracia

    Joined:
    Dec 24, 2015
    #9
  9. peter.boling macrumors newbie

    Joined:
    Jun 1, 2015
    #10
    I am also having the same issue on El Capitan, and have "No Updates Available". Force quitting does not help, the process just restarts. My fan has been running constantly for days! Even when I don't have contacts or messages apps open the soagent is chewing up my machine.
     
  10. ryanbeymer macrumors newbie

    ryanbeymer

    Joined:
    Dec 28, 2015
    #11
    I was able to easily replicate and stop it from happening by disabling the contact syncing on my google account in Internet accounts.

    I have 1 gmail and 3 google apps accounts but it is only one of the google apps accounts that does it. If anyone knows how to identify the conflict I'm willing to give it a try.
     
  11. alt256 macrumors newbie

    Joined:
    Dec 29, 2015
    #12
    Same problem here. I have 1 gmail account and 2 google apps accounts. I've unchecked the contact syncing option for the latest google apps account added yesterday, and problem is solved. Maybe it's because this account is new and doesn't have any contacts yet???
     
  12. ryanbeymer macrumors newbie

    ryanbeymer

    Joined:
    Dec 28, 2015
    #13
    Not related to 0 contacts, I have plenty in there.
     
  13. aamm06 macrumors newbie

    Joined:
    Dec 30, 2015
    #14

    Thank you so much, **** my contacts, i can import them manually... needed my computer more than contacts on a computer that didn't work!!
     
  14. nikespex macrumors newbie

    Joined:
    Feb 23, 2011
    #15
    I had the same issue (high cpu usage by soagent and callservicesd) after upgrading my Macbook to El Capitan. This thread helped me isolate the issue to syncing contacts with my Google Apps account. Unchecking contacts from the Google Apps account in System Preferences > Internet Accounts resolved the CPU issue.

    But wait - I want contact syncing! After viewing some related posts in the Apple Support forums I tried repairing disk permissions (Disk Utility > First Aid) and this has resolved the issue. Contact syncing for Google Apps is back on, but without high CPU.
     
  15. luvis macrumors newbie

    luvis

    Joined:
    Jan 9, 2016
    #16
    I have this problem as well like many others. I installed an app called AppPolice which enables cpu limitation on any given process on the system. At least it's a temporary fix... Hope it helps someone
     
  16. Enrico Bermudez macrumors newbie

    Enrico Bermudez

    Joined:
    Jan 13, 2016
    #17
    SYMPTOM: High CPU usage by "soagent" process. The computer gets very hot and the fan starts blowing.

    WHEN: In hindsight, it started happening when I added my work's Google/Gmail account as one of the internet accounts in my MacBook.

    THE FIX: Turn off all the sync'ing of your contacts, except for one Google account's contacts list. (You can do this by searching for "Internet Accounts" -- which you can also find under System Preferences. Anything above 1 Google account sync'ing their Contacts restarted the high CPU (and having the computer heat up and the fan blowing high again). So I chose only one account that will be sync'ing its Google Contacts.
     
  17. CaliKev macrumors member

    CaliKev

    Joined:
    Jun 24, 2007
    Location:
    Seattle, WA
    #18
    I haven't updated to 10.11.3 yet, but I can also confirm that disabling the contacts syncing for my google accounts resolved this issue too. I was having the exact same problem until I disabled the issue. Yay for google searches!!! Thanks @alt256 for the workaround!! :)
     
  18. JD92 macrumors 6502a

    JD92

    Joined:
    Apr 14, 2005
    #19
    Hi all

    Just here to report that I'm having this exact same issue. My enabling Contacts syncing for my Google Apps account results in the Contacts app working very slowly on both my 2015 MacBook and 2012 Retina MacBook Pro. It also results in Contacts.app and accountsd having very high CPU usage and Energy usage according to Activity Monitor.

    The problem only happens with my Google Apps account, not with my regular gmail.com account.

    If you're having this issue, make sure you report it at apple.com/feedback
     
  19. warrenkerrigan macrumors newbie

    warrenkerrigan

    Joined:
    Jan 22, 2016
    #20
    Hi there

    After much messing about, here is what worked for me.

    1. Remove all Internet Accounts
    2. Reboot the machine (just to be safe)
    3. Add back the Google Apps account and let it settle down (took about an hour I think). It wasn't at 100% CPU this time, but both processes were working hard.
    4. Once it settled down, I added the other accounts (iCloud, LinkedIn, Facebook, second Google Apps without Contacts sync turned on), etc

    After that everything seems normal, and has been for the last two days.

    I hope that helps someone else. Its a bit of a faff, but at least you can get back to normal CPU life.

    Warren
     
  20. spachner, Jan 23, 2016
    Last edited: Feb 7, 2016

    spachner macrumors newbie

    Joined:
    Jan 23, 2016
    #21
    Had the same issue with high cpu because of soagent. Running 10.11.2. Updated to 10.11.3, problem persists.

    Solved with:

    o remove from Internet accounts: Google
    o reboot
    o add same Google account again
    o done
    o blame Apple

    spachner
     
  21. slebbo macrumors newbie

    slebbo

    Joined:
    Jan 25, 2016
    Location:
    Tellus
  22. Jbryancoop macrumors newbie

    Jbryancoop

    Joined:
    Jan 26, 2016
    #23
    Having the same issue, disabled google syncing which did clear it up, but I am also finding that when I try to share a contact card (iCloud) via iMessage, contacts crashes. Anybody seen this?
     
  23. tigres macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #24
    Thread watcher, now poster.
    This issue (same for me, callservicesd, soagent) is driving me mad. I have it hitting 120% CPU on restarts, and on and off during the day. When I re-boot, my fans go to 6400 for about 5 minutes. I do NOT use Google contacts syncing; only iCloud which I am blaming for this.

    If I turn off contacts and calendar syncing with iCloud, system acts as normal.

    I have tried everything mentioned on the net, nothing helps. As soon as syncing is turned back on the problems come back.

    This is so pissing me off; and I was going to just put the beta 3 on my machine until I saw it is not fixed yet.
    Another probable iCloud wondrous "not working as it should" phenomena.
     
  24. jcschell macrumors newbie

    Joined:
    Feb 4, 2016
    #25
    I was also experiencing same issues as others: high CPU, high fan speed ...
    All issues stopped when I turned off contact syncing to gmail.
    Permanent Fix for me was to switch to BusyContacts . More power, less fan noise!
     

Share This Page