Contacts do not appear first anymore

Discussion in 'iOS 9' started by geopal, Oct 13, 2015.

  1. geopal macrumors newbie

    Joined:
    Oct 3, 2015
    #1
    Has anyone notice that after iOS 9 update, when making a search messages & mail appear first and then contacts like it used to be?
    If i search for "John" for example, the first results will be message or mail from "John" and then the contact to call.
    Anyone know how to fix it?

    PS I dont want to disable search in messages and mail, just have contacts appear first
     
  2. gixxerfool macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #2
    Taking a cursory glance, I'm pretty sure you used to be able to, now it looks like it's on or off. I could be wrong though.
     
  3. Four oF NINE macrumors 68000

    Four oF NINE

    Joined:
    Sep 28, 2011
    Location:
    Hell's Kitchen
    #3
    Is there some reason contacts don't sync between iOS and OS X ?
     
  4. geopal thread starter macrumors newbie

    Joined:
    Oct 3, 2015
    #4
    So there is no such option now? It sucks to look for a phone number and have messages or mails from this number appear :(
     
  5. Sonnto macrumors member

    Sonnto

    Joined:
    Oct 10, 2015
    Location:
    Toronto, ON
    #5
    For me, they appear on top. When I search "Sonnto", I get myself in the contacts first. Then I get messages at the times when I felt lonely and messaged myself. And then I get mail, the times I e-mailed myself, etc.

    A reason for contacts not syncing between iOS and OS X could be your Settings > Mail, Contact, Calendar > Fetch New Data > iCloud is set to anything but PUSH.

    Under Fetch, it will sync in a set interval that you set it, be it 15 min, 30 min, or 1 hr. So the reason why contacts may not be synced in this case would be because it hasn't "Fetched" new data yet--it hasn't hit the 15/30min/1hr interval yet.

    Push means it will automatically, within several seconds, sync when there is a change detected on either end. You should always be synced in this case, unless you are data-less, meaning no wifi or mobile data to make a connection to the internet.

    Manual means you must open up your Contacts app (and by extension, all the other apps that are related to what is stated under "iCloud") in order to sync it. In this case, your contacts don't sync because you haven't opened put the Contacts app in quite a while.

    I set my iCloud to Fetch or Push, (push currently). My Holiday Calendar is set to Manual since Federal Holidays are not usually changed that often to merit a Fetch or Push. Everything else is Fetch with 1 hr interval.
     
  6. geopal thread starter macrumors newbie

    Joined:
    Oct 3, 2015
    #6
    Thanks for your reply but I don't think it's a sync problem. Contacts appear ok in the contacts app. The problem appears when I'm doing a search where it has always been showing contact results first and then maybe messages or mails. Now with iOS 9 for some reason it displays first the messages, mail, apps and then at the end the contacts, which is annoying
     
  7. geopal thread starter macrumors newbie

    Joined:
    Oct 3, 2015
  8. sohanangal macrumors member

    Joined:
    Sep 24, 2012
    Location:
    India
    #8
    I faced this problem as well. My problem was even weirder, I could not see the Contacts at all, though I saw the messages and mail from that contact. This problem was pretty much solved on upgrading to iOS 9.1, though it does occur once in a while! Hoping for a permanent fix.
     
  9. Paco II macrumors 65816

    Joined:
    Sep 13, 2009
    #9
    I am guessing that Spotlight now uses an algorithm to determine what it thinks is likely to be the most likely correct result. Does it 'learn'? If you frequently select someone from contacts does it move it to top? For me, contacts are listed above messages.
     
  10. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #10
    Spotlight search is a function I do not use. For example, if I want to look up a contact, I go to the contact app and search from there. Look for an event, bring up the calendar (Fantastical, actually).

    That said, seems to be working for me, or, not strange/makes sense. Search for a frequent contact of mine, by first name, pulls up first the title of a podcast I listen to every weekday (host and friend share same first name), contact for friend shows next, all under "Top Hits". A different contact next with same name, then my e-mails from the friend. Calendar events next.

    Going to go with Paco II on this: some heuristics on most likely/most used item(s) that match the search.
     
  11. geopal thread starter macrumors newbie

    Joined:
    Oct 3, 2015
    #11
    Thought it was working like that but doesn't seem so! Does not seem to remember the most frequent searches I do :(
     
  12. geopal thread starter macrumors newbie

    Joined:
    Oct 3, 2015
    #12
    Found the solution in another forum. Thanks anyway. Does anyone know how to disable full screen caller id?
     
  13. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #13
    And that solution is what?
     
  14. geopal thread starter macrumors newbie

    Joined:
    Oct 3, 2015
    #14
    Turned off all sliders from spotlight search results, restarted then enabled just contacts and restarted back
     
  15. uhaas macrumors 6502

    uhaas

    Joined:
    Aug 31, 2012
    Location:
    Twin Cities, MN
    #15
    The real issue is you used to be able to order spotlight search results befor iOS 9, now you can't. I filed a bug right after iOS 9 came out because I suffered this as well.

    I also shut a bunch of other apps off on spotlight search results. It helps. There are many apps I don't need spotlight searching for. Why would I need AngryBirds content showing up in spotlight search?
     

Share This Page