Contacts doubled in iPhone 3.0

Discussion in 'iPhone' started by risenphoenixkai, Jun 10, 2009.

  1. risenphoenixkai macrumors member

    Joined:
    Oct 14, 2008
    #1
    Since upgrading to OS 3.0, I noticed the behaviour in the Contacts app has changed. I now have two separate sets of contacts, one called "On My iPhone" and the other called ".Mac (MobileMe)".

    The thing is, both of these lists contain the exact same information, so when I go to "All Contacts", every single one of my contacts has two entries.

    Is there any way for me to fix this and get it to display only one instance of contacts? It's pretty annoying.

    I do not have iTunes set to sync contacts to the phone; it's all done over the air with MobileMe.
     
  2. dissdnt macrumors 65816

    dissdnt

    Joined:
    Aug 3, 2007
    #2
    Yah I'm in the same boat. Doesn't seem to unsync if you told it once sync from your mac and mobile me.

    Right now I just have in groups my mobile me address book selected.

    Same problem in Calender if you tell itunes to sync it and you have mobile me.

    So if anyone know how to remove that, would be nice hehe.
     
  3. thefunkymunky macrumors 65816

    Joined:
    Feb 24, 2005
    Location:
    London
    #3
    Duplication of Contacts

    What's happening here? Why the duplication of my contacts? I've just synced my iPhone with iTunes again and now they are triplicated. The contacts only appear once in MobileMe and Address Book :unsure: Running iPhone 3G with 3.0 software and the default v4.0 O2 carrier file. :eek::confused:
     

    Attached Files:

  4. Abyssgh0st macrumors 68000

    Abyssgh0st

    Joined:
    Jan 12, 2009
    Location:
    Norman, OK
    #4
    Yeah, it did it me because of MobileMe.

    And I'm fine with just keeping it in the "Group" for MobileMe, so it's just single contacts.
     
  5. iphones4evry1 macrumors 65816

    iphones4evry1

    Joined:
    Nov 26, 2008
    Location:
    California, USA
    #5
    I can definitely see how this could be a problem.
     
  6. gloss macrumors 601

    gloss

    Joined:
    May 9, 2006
    Location:
    around/about
    #6
    I had the same thing happen when I synced my phone to Google. It doesn't provide the option to sync just to Gmail - you have to select Sync Address Book and Gmail simultaneously.
     
  7. prospereagle92 macrumors regular

    Joined:
    Jul 29, 2008
    #7
    i have the same problem, but it combined a few of my contacts so i say the names are Jay Johnson and James West it made it Jay West and James West...and both have the phone numbers for each.
     
  8. risenphoenixkai thread starter macrumors member

    Joined:
    Oct 14, 2008
    #8
    I found out from the Apple forums how to fix this issue.

    In the settings for the iPhone, under Mail, Contacts, Calendars, disable MobileMe syncing of Contacts (and Calendars if those are duplicated, too, as mine were).

    The iPhone will ask you for confirmation to remove the MobileMe data. Confirm.

    Once the MobileMe contacts are purged from the iPhone, re-enable MobileMe contacts syncing. The iPhone will then bring up another prompt; I don't remember what the other option was called exactly, but the option you want is "Merge contacts".

    Fixed. No more duplicate contacts.
     
  9. chgojcs macrumors member

    Joined:
    Feb 9, 2008
    #9
    Okay, the issue seems to be syncing with iTunes and MobileMe.

    Here is what finally worked for me, both with Calendars and Contacts.
    Follow the steps listed above, then TURN OFF syncing of contacts and calendars in iTunes, then sync again. It should work, as it appears 3.0 is handling the syncing of contacts and calendars differently. If you are syncing over the air, it will do it automatically, and you do not need to sync contacts or calendars with your computer.

    At least this worked for me.
     
  10. JForestZ34 macrumors 6502a

    Joined:
    Nov 18, 2007
    #10

    This happened to me also and I tried unsyc mobile me and when it asked me to merge it I pushed no and I don't have duplicate contacts


    James
     
  11. jaydie515 macrumors newbie

    Joined:
    Feb 27, 2008
    Location:
    New York City
    #11
    This worked for me... thanks!
     
  12. masai29 macrumors newbie

    Joined:
    Jun 27, 2009
    #12
    I'm having the same problem with my iPhone 3GS. I"m having trouble following your instructions, though. Not sure what you mean by "disabling MobileMe syncing of Contacts."

    On my iPhone under Settings > Mail, Contacts, Calendar, I only see the following options that I can change:

    "Sort Order"
    "Display Order"
    Default Account"

    I don't see anything that enables me to disable MobileMe syncing. Under the "Default Account" I can choose either "From My Mac" or my MobileMe account. If I choose "From My Mac" I don't get any kind of confirmation message to remove MobileMe data as you describe.

    Please help! This is really annoying!!

    Steve
     
  13. renewed macrumors 68040

    renewed

    Joined:
    Mar 24, 2009
    Location:
    Bemalte Blumen duften nicht.
    #13
    Hate to thread jack but this didn't seem necessary to start a new one with but I needed to rant.

    3.0 has caused phone numbers to go all over the place. Numbers under the wrong names, wrong pics for people, emails all over, numbers getting deleted off names, some names having up to 6 numbers listed!!!!

    Appointment with a Genius on Monday. It's interesting now though. I cross my fingers that I'm texting the right person lol
     
  14. DotCom2 macrumors 68030

    Joined:
    Feb 22, 2009
    #14
    The same thing happened to me and it was very frustrating.
    I finally figured it out though.
    I am using a PC so if you are on a MAC you will have to adjust accordingly but the reason you have double contacts is because once you copied your contacts over to Mobile Me and then synced, you did not remove the check mark in iTunes to sync with contacts in iTunes. In other words, you synced with Mobile Me *AND* iTunes. MM does not know you synced with iTunes, and iTunes doesn't know you already synced with MM. You have to sync with one or the other but not both!
    Once you get the double contacts etc. the only way I could fix it was to temporarily disable auto sync with MM. Then totally delete your MM mail account on your iPhone. Then go into iTunes and UNCHECK syncing with contacts etc. Then sync with iTunes. All your contacts should be gone now.
    Now set up your MM mail account again on you iPhone and check it to sync your contact etc. with Mobile Me.
    Don't forget to set it back to auto sync if that's what you want but don't ever sync your contacts etc in iTunes or you'll double everything again.
    I hope that was clear.
    Good luck.:D
     
  15. WaldenGirl66 macrumors newbie

    Joined:
    Sep 27, 2009
    #15
    Please Help!!!

    I am having the same kind of issues, although I am using Google Mail not mobile me. My google contacts are being synced "Over the Air" using exghange.

    When I goto contacts on my iPhone There are two groups:
    On my iPhone
    Google mail (exchange)

    I cannot figure out what I need to do to get rid of the "On my Iphone " group.

    Any help would be GREATLY appreciated!!

    Thanks Carol-Ann
     

Share This Page