Contacts, Gmail, Exchange, (again)

Discussion in 'iPhone' started by slr001, Oct 26, 2011.

  1. slr001 macrumors member

    Joined:
    Oct 11, 2011
    #1
    So here is what I am trying to do...

    I have two primary email accounts. One is a corporate email, one is gmail

    I have set it up as 2 Exchange accounts, one pointing to my work exch server, one pointing to google.

    I have painstakingly cleaned up and edited all of my contacts on google contacts and saved them to a backup. I then used itunes to bring them into the contacts on the iPad/iPhone (4s). Now I have all of the same contacts on each device.

    What i want is that when I add a contact to google contacts that it gets pushed to my phone. When I add a contact to my phone, it gets pushed to google contacts. Preferably without having to sync via itunes, but if need be then so be it.

    If I turn on contacts for my work email, and for gmail... I get 4 new contact lists, gmail, gmail global, work, work global. Plus all contacts and "All from my PC" (this is the google import).

    Surely there is a simple solution that I am overlooking... I want the "work global" because it lets me search the entire work contact database for colleagues that i dont have in my contacts yet. The gmail and gmail global seem the same?
     
  2. DefBref macrumors 6502

    Joined:
    Feb 26, 2011
    #2
    Turn off syncing with itunes for contacts.

    Just use the exchange accounts. I also have the global but have always ignored them and updating contacts on the phone are pushed to gmail and vice versa. I think your just overthinking it.
     
  3. slr001 thread starter macrumors member

    Joined:
    Oct 11, 2011
    #3
    Works partially. I turned off syncing in iTunes. I have contacts selected in Exch/work, and Exch/gmail.

    I now have 5 contact groups All/Work/WorkGlobal/Gmail/GmailGlobal

    If I create a contact in Outlook it shows up on the phone as All/Work. If I create in Gmail, it shows up in All/Gmail... Perfect

    If i create on the phone, in the All group, it also ends up in All/Work, but not in the Gmail group. It gets pushed to Outlook on my computer, but not to my Gmail account. Not so perfect.

    I looked in my Gmail settings to see if I need to flip a switch to allow it to receive contacts, but didnt find anything.
     
  4. DefBref macrumors 6502

    Joined:
    Feb 26, 2011
    #4
    Oh, didn't realise you wanted the two exchange accounts to sync to each other, not sure that's possible and you'll end up with duplicates anyway so not sure why you would want to.
     

Share This Page