Contacts not being added/ms exchange

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mpossoff, Aug 12, 2011.

  1. mpossoff macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
    #1
    I uploaded ms exchange on my iPhone and got all my contacts. But when I input contacts manually they are not going into ms exchange. I assume it gets them from google contacts?

    How do you get contacts added manually into the ms exchange/google contacts?
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    For a start, need more info to help:

    Email/contacts provider
    Account setup type on phone
    Contact sync settings in iTunes
     
  3. mpossoff, Aug 13, 2011
    Last edited: Aug 13, 2011

    mpossoff thread starter macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
    #3
    Email/contacts provider: Gmail
    Account setup type on phone: see attached
    Contact sync settings in iTunes: see attached
     

    Attached Files:

  4. mpossoff thread starter macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
  5. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #5
    If you're syncing Gmail contacts on your phone you should uncheck all of the contact syncing in iTunes. Just causes problems. When you add a contact to the Gmail contact group on your phone it should update the contacts at Gmail.

    See my tips post for setting up Address Book on the Mac. I haven't tested these settings in Lion, yet.
     
  6. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #6
    Deep down in your Mail, Contacts, and Calendar settings, there is an obscure option for Contacts - Default Account. Change it from On My iPhone to the name that you gave your Exchange account. Then it will add them to Exchange instead of just the local list. And like previous posters said, disable iTunes from syncing this, otherwise you'll get duplicates.
     
  7. mpossoff thread starter macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
    #7
    On my iPhone I have 2 accounts. A gmail account for mail and an exchange account for contacts. Under exchange account mail is off since I have account for mail.

    I did what you said and changed default to exchange account. So now manually added contacts should be added to exchange account?

    Also in my contacts app there's a groups which I'm confused about. All Contacts, All on My iPhone and Exchange. When I choose All Contacts manually added contacts show up. When I choose All on my iPhone I only see manually added contacts. When I choose Exchange I don't see manually added contacts?
     
  8. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #8
    My method won't add the contacts currently on your phone. It will only upload the ones that you input from now on. You'll have to add them ones that have been missed manually.

    Edit- Once you manually add the contacts either through Exchange online or through your phone with the new settings, the Exchange list will contain all of your Contacts.
     
  9. mpossoff thread starter macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
    #9
    When I add a contact manually on my iPhone am I suppose to add it in the MS Exchange group?
     
  10. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #10
    If you're in the group called All Contacts, it'll automatically add it to your exchange account. Or you can be in just the Exchange group too.
     
  11. mpossoff thread starter macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
    #11
    I changed settings as per suggested bellow so hopefully this will solve my issue?

    How can I find out if manually added contacts are added/synced to Exchange?
     
  12. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #12
    Only way to see if it's in the right group is to go back and forth between the groups to see what's missing. Or browse through your Contacts online and compare the list that way.
     
  13. mpossoff thread starter macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
    #13
    Google contacts online?
     
  14. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #14
    Yep
     
  15. mpossoff thread starter macrumors 68020

    Joined:
    Mar 21, 2010
    Location:
    Philadelphia
    #15

    They are showing up!!!!

    I wonder if changing default to Exchange account did it.
     

Share This Page