Tomb01

macrumors 6502
Original poster
Jan 6, 2009
402
24
Colleyville, TX
My iPhone and iCloud contacts seem to synch normally. However, my MacBook contacts does not. I have iCloud setup on my MacBook, and other things seem to synch normally (photos, notes, etc), but not contacts. Am a bit reluctant to just clear all my local contacts and reload from iCloud, especially as I am uncertain they will actually synch... Any thoughts on how to debug this?

Thanks in advance.
 

Biro

macrumors regular
Jan 11, 2012
133
84
I have the same problem with my iMac. My iPhone and iPad synch contacts perfectly. But my iMac won't update. Contacts are activated in iCloud on all my devices. But when I check iCloud.com, the contacts list is the same dated list that's on my iMac. I can update my contacts on iCloud.com. But shouldn't it happen automatically like on my iOS devices? Backing up the iPhone and iPad makes no difference.
 

Apple_Robert

Contributor
Sep 21, 2012
27,903
34,576
In the middle of several books.
I have the same problem with my iMac. My iPhone and iPad synch contacts perfectly. But my iMac won't update. Contacts are activated in iCloud on all my devices. But when I check iCloud.com, the contacts list is the same dated list that's on my iMac. I can update my contacts on iCloud.com. But shouldn't it happen automatically like on my iOS devices? Backing up the iPhone and iPad makes no difference.
I believe the website version of iCloud (contacts) is the main hub so to speak, and it all revolves around what is seen on the web. You are going to have to manually edit the website so that it shows what you want it to show. Once edited, it should start syncing like it I is supposed to across devices.

I realize you shouldn’t have to manually edit when you have multiple devices. All I can say is there are some ongoing flaws with iCloud contact syncing.
 

Tomb01

macrumors 6502
Original poster
Jan 6, 2009
402
24
Colleyville, TX
Have not tried switching off then restarting. Have turned it off and on again without restarting... Will try the restart action and report back.
 

Tomb01

macrumors 6502
Original poster
Jan 6, 2009
402
24
Colleyville, TX
Have not tried switching off then restarting. Have turned it off and on again without restarting... Will try the restart action and report back.
Sigh, sadly no change. My iCloud contacts have different information than my Macbook contacts. Turned off contact synching on my my Macbook, restarted, then turned it back on, but no change. In fact, if I open contacts and try to change to iCloud it does not reflect the information in my iCloud address book.... Will research 'clearing' my Macbook contacts and seeing if they repopulate with my iCloud/iPhone information...
 

Ruggy

macrumors 6502a
Jan 11, 2017
578
330
If I understand you've tried switching contacts off in icloud then on again?
Have you tried logging out of icloud on the mac and logging in again?
It's usually something like this that works.
Also, under contacts>preferences>@accounts, make sure fetch is set to automatically.
Oh, and you must have the account enabled of course and it must be the same email address enabled as your Apple sign in account.
 

mk313

macrumors 65816
Feb 6, 2012
1,313
564
Tomb01, your process is a little unclear. Just to follow up on what Ruggy said, have you turned off ICLOUD SYNCING (under Apple ID in preferences) for contacts on the Mac (not turned off the Mac altogether)? If not, I'd start there. I had the same issue with my iPad in the past & the solution was to turn it off, then turn it back on again. I forget if you get a popup to save the contacts on your computer or if it does it automatically when you unsync, but it won't just automatically delete the contacts on your Mac if you unsync.
 

ApfelKuchen

macrumors 601
Aug 28, 2012
4,032
2,577
Between the coasts
If the contacts in iCloud.com do not match your iPhone and iPad, then the problem is between the iPhone/iPad and iCloud, not your Mac. Your Mac is simply reflecting the state of iCloud.com from the sound of things.

Isolate the point(s) of failure:

Focus on making sure every one of your devices is syncing to iCloud.com - that's the central point.

Create a new contact on iCloud.com - does it appear on your iPhone, your iPad, your Mac?
If it doesn't appear on your iPhone, you have a problem with the iPhone
If it doesn't appear on your iPad, you have a problem on your iPad
If it doesn't appear on your Mac, you have a problem on your Mac

Maybe you have a problem in more than one place.

Sometimes the problem is one-way, so in addition to creating that test contact on iCloud.com, create one on your iPhone, create another on your iPad, and another on your Mac (name each test contact differently, to keep track).
Do they all appear at iCloud.com? Again, if they don't, it tells you which device(s) have a problem.

Do not assume that a newly-created contact has been created in your iCloud account. Contacts can also be created /synced to other mail accounts (Gmail, Yahoo, AOL, Outlook, Exchange Server, etc.). So you need to check Settings > Contacts > Default Account on iPhone/iPad, and Contacts > Preferences > General > Default Account on Mac.

It's also possible that you're simply not viewing your iCloud contacts on one or more of your devices. On iPhone/iPad open the Contacts app and tap on Groups in the upper-left corner. Be sure there's a check-mark for iCloud. To be sure you're viewing only your iCloud contacts (to reduce confusion during troubleshooting), un-check any other contacts accounts. Similarly, in Mac Contacts be sure you're viewing the Groups sidebar (Contacts > View > Show/Hide Groups) and then click All iCloud in the Groups sidebar to view only iCloud.

There's more that can be said, but this methodology should point you in the right direction.
 

Ruggy

macrumors 6502a
Jan 11, 2017
578
330
Another thing that might help.
If you sign into icloud via a browser on the net, and go to account settings, then scroll down to 'advanced'
you'll find an option to restore contacts from a backup.
You should find several backups to choose from.
This has two uses: firstly, if you do something and mess up your contacts then you can restore them so don't worry about that. Just check you have some backups first.
But also you can use it to resynch your contacts with all your devices.
The best in your case would be to go to the phone> icloud backup and do the 'backup now' option.
Then go to the cloud and restore from that backup.
It should restore all the contacts on all your devices and it maybe that after it's done that your mac will work normally again.
If it doesn't talk to your mac and nothing changes at this point then....erm...?
 

Jasonondesign

macrumors newbie
Nov 30, 2020
11
2
northampton ma
Having the same problem. What I realized is new contacts were not automatically created in iCloud. To fix this:

1) go to contacts.app (formerly address book)
2) on lefthand sidebar click on "All Contacts)
3) Command-A to select all in middle column
4) Drag all contacts from middle column to "All iCloud"

Not sure if there's a way to fix it so that new contacts are automatically created in iCloud or not.
 

ApfelKuchen

macrumors 601
Aug 28, 2012
4,032
2,577
Between the coasts
Not sure if there's a way to fix it so that new contacts are automatically created in iCloud or not.
Absolutely is. Contacts (drop-down menu) > General > Default Account

You'll find a Default Account option in the app Preferences on Mac, and in app Settings on iOS/iPadOS for Mail, Contacts, Calendars, Notes, and Reminders.
 

Jasonondesign

macrumors newbie
Nov 30, 2020
11
2
northampton ma
@ApfelKuchen I think they might have removed that in Big Sur. Here are the only options I have in general preferences on my Mac.

Screen Shot 2021-03-28 at 4.34.18 PM.png
 

ApfelKuchen

macrumors 601
Aug 28, 2012
4,032
2,577
Between the coasts
@ApfelKuchen I think they might have removed that in Big Sur. Here are the only options I have in general preferences on my Mac.

View attachment 1750593
It's still in Big Sur, but you do have to have more than one contacts account enabled. If you have multiple accounts enabled, you will have another drop-down box for Default Account. Actually, it works this way on all platforms and versions of iOS and Mac - if there's a single account there's no need to select a default, so the checkbox/drop-down list is deprecated.
 

Jasonondesign

macrumors newbie
Nov 30, 2020
11
2
northampton ma
Awesome! I turned on a second account, and then set it, and then turned it off. I dont' know why it was defaulting to "local contacts" instead of "iCloud". That option isn't even in the pulldown.
 

ApfelKuchen

macrumors 601
Aug 28, 2012
4,032
2,577
Between the coasts
Awesome! I turned on a second account, and then set it, and then turned it off. I dont' know why it was defaulting to "local contacts" instead of "iCloud". That option isn't even in the pulldown.
If there's no cloud-based account selected, an "on this device" account will be created - those contacts have to be stored somewhere. Once "on this device" has been created it can continue to exist. If iCloud Contacts are later enabled you'll be asked whether you want to merge "on this device" into iCloud. Once merged, "on this device" will disappear. However, there is not an option to automatically merge "on this device" when you enable third-party cloud contacts like Google or Yahoo. On iOS there's no easy way to move contacts from one account to another (there than the example I gave previously). On Mac, however, you can drag and drop to copy selected contacts into another account.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.