Contacts showing 'Linked Cards'?

Discussion in 'iOS 5 and earlier' started by CosmoPilot, Oct 13, 2011.

  1. CosmoPilot macrumors 65816

    CosmoPilot

    Joined:
    Nov 8, 2010
    Location:
    South Carolina
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    I have iCloud set up, and I just noticed that all my contacts show 2 Linked Cards. 1 is called "Unified" and the other is called "iPhone"

    This is found at the bottom of each contact. Anyone know what this is all about? The main reason I ask, is the unified card gets updated when I make a change but the iPhone card doesn't.

    Guess it goes without saying, I'm using an iPhone right now.
     
  2. dbro macrumors newbie

    Joined:
    Jun 7, 2011
    #2
    The problem is that your phone is storing invisible contacts in its database. Just for reference, were you part of the iCloud beta?

    The way I fixed this problem is by using a 99 cent app called Cleanup which for some reason can see the contacts that the Contacts app won't.

    First turn off iCloud contacts on your phone and tell it to Delete contacts from phone

    Then run Cleanup, and select all and delete.

    Then turn iCloud contacts back on. You should be only seeing the single entries now!
     
  3. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #3
    There's a basic problem at work here - the multiple syncs. The links icon means there is more than one file on that person.

    If you are using Gmail, your contacts are being synced there. A double sync occurs when you also sync contacts to iCloud. There's also a potential third sync - Verizon's auto backup.

    You will end up in a huge MESS if you don't limit contact syncing to Gmail only. Trust me, I learned the hard way. You will have old, duplicated, deleted, etc information thrown in the mix.

    First: Turn off iCloud sync for contacts
    Second: Turn off Vz's auto backup
    Third: Go to your My Verizon account. If they have any contacts listed, DELETE them ALL. Don't panic, Gmail has your contact's list - it's not the same as Vz's.

    The best thing is not to activate the Vz auto-backup at all. Just causes problems. The My Verizon backup contacts list is the worst offender because Vz backup doesn't update often, so old, outdated and stray data is thrown in. iCloud compounds the problems.

    When I discovered all this, it took me DAYS to clean up my Gmail contacts. While cleaning up, be sure to look for a bunch of contact info under something like "unsorted" or a similar name - it contains duplicates, too. But, be sure to do a test delete before getting rid of them, so you know for sure you aren't deleting from your main list.

    Good luck!
     
  4. Arelunde, Dec 5, 2011
    Last edited: Dec 5, 2011

    Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #4
    I should have added in the above post that Gmail contacts need to be synced through iTunes. Gmail email and calendar sync OTA on their own, but the contacts don't.

    In iTunes, check sync to Gmail/Google contacts but DON'T have the calendar sync, too, (unless you are using Outlook or something else).

    Mods: This issue is so common and I write this answer so many times that maybe this thread merits being a sticky???
     
  5. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #5
    Huh? why would u do that? Everything syncs via exchange sync. I have it setup that way and its working fine. Why would u sync gmail contacts via itunes?
     
  6. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #6
    Because there's no option in Settings > Accounts > Gmail to sync contacts - only calendar, notes and email.
     
  7. crashnburn, May 19, 2013
    Last edited: May 28, 2013

    crashnburn macrumors 6502

    Joined:
    Nov 18, 2009

Share This Page