Contextual menu (right/ctrl-click) delayed in Lion

Discussion in 'Mac OS X Lion (10.7)' started by star-affinity, Jul 20, 2011.

  1. star-affinity macrumors 6502a

    star-affinity

    Joined:
    Nov 14, 2007
    #1
    Since upgrading to Lion on my MacBook Pro I notice the time it takes to bring up the contextual menu (the one that comes up when right/ctrl-clicking and ”two finger tapping” on the trackpad) is a little delayed in Lion. It's not by very much, but still very noticeable (especially in Safari I think) and it now feels more like how it is in Windows which in this case isn't a good thing. :(

    Not a big issue one might say, but in the long run time adds up.
    In Snow Leopard it was more or less instant for me.

    Anyone else noticed this?
     
  2. iHateMacs macrumors 6502a

    iHateMacs

    Joined:
    Aug 13, 2008
    Location:
    Coventry, UK
    #2
    It's because it's waiting to see if you are double two finger tapping. If you disable the double two finger tapping then it will be instant as before.
     
  3. aresinferno macrumors regular

    Joined:
    Oct 13, 2008
    #3
    EDIT: Turn Smart Zoom off and it will be instant.
     
  4. star-affinity thread starter macrumors 6502a

    star-affinity

    Joined:
    Nov 14, 2007
    #4
    Thanks guys!
    Disabling ”Smart zoom” in the Trackpad preferences did the trick.

    While I can see that Smart zoom is a nice feature in some cases I don't think I'll use it that often so I'd rather have a snappy contextual menu – at least that's how I feel about it now. :)
     
  5. millerrh macrumors 6502

    Joined:
    Sep 14, 2005
    #5
    Glad I found this, this was bugging me too. I use right click way more than I'll ever use smart zoom. Bye bye smart zoom, too bad Apple had to make compromises including you.
     
  6. cgm707 macrumors member

    Joined:
    Dec 24, 2009
    #6
    Right-click not working

    Right-clicking on the trackpad is not working for me. I disabled Smart Zoom, and every time I click the Secondary Click option under System Preferences/Trackpad, this box somehow gets unchecked!

     

Share This Page