Continued headaches with wifi

Discussion in 'iMac' started by one1, Mar 1, 2013.

  1. one1, Mar 1, 2013
    Last edited: Mar 1, 2013

    one1 macrumors 65816

    Joined:
    Jun 17, 2007
    Location:
    Chattanooga, TN
    #1
    Both my 27" and my 21" iMacs suffer from wifi issues after sleeping or from cold boot. They say they are connected to the router, but have an exclamation point for lack of internet connection.

    I have done extensive research and tried some of the fixes like deleting the preferences files for airport from the /Library folder, but the issue still remains on BOTH iMACS.

    I know this is an issue for many running Mountain Lion (and Lion) with newer iMacs. What have YOU done to solve issues with wifi? I'm about to have to go back to Snow Leopard.

    EDIT: I wanted to say I have no issues with anything but my iMacs which are 2010 and 2011, both on 10.8. My Macbook on 10.8 (2010), ipads (2 ipad 2's), and iPhone 4s all work properly on this router.
     
  2. FuriousGreg macrumors member

    Joined:
    Nov 11, 2011
    #2
    It sounds to me like its a problem with the router rather than the wi-fi connection. The router may need to be restarted or reset. I would suggest trying this:

    1) Shut off your computer/iPad etc.
    2) unplug your wi-fi router and modem
    3) unplug your the eathernet connection between the modem & router.
    4) wait five minutes
    5 ) in this order:
    a) reconnect the ethernet connection
    b) plug in the modem, wait until the modem's start-up process is finished
    c) plug in the router and wait until it's start up is finished
    d) turn on your computer.
    Hopefuly you will get a connection.
     
  3. one1 thread starter macrumors 65816

    Joined:
    Jun 17, 2007
    Location:
    Chattanooga, TN
    #3
    Thank you for your response, and not to discredit it at all, but it's only those two machines out of that huge list, and that doesn't account for the Wii, my wife's android, or her HP laptop..... All of which work fine. As well I haven't had any issues on Snow Leopard, and this seems to be a largely reported issue with Mountain Lion from what I see on google. Therefore I am just trying to troubleshoot it from every angle within the OS, and I appreciate the response.
     
  4. Raima macrumors 6502

    Joined:
    Jan 21, 2010
    #4
    Are you using static ip or dhcp?

    If you use dhcp, reserve ip addresses for your mac
     
  5. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #5
    I'd never use a stationary computer in WiFi, wired Ethernet is just so much faster & stabler.

    If you must use WiFi make sure your router is a quality unit not some PoS from the ISP.
     
  6. Brian Y macrumors 68040

    Joined:
    Oct 21, 2012
    #6
    As a rule of thumb with networking issues - if more than one device (out of a list of however many) is experiencing the same issue, it's very unlikely to be the computers at fault.
     
  7. one1, Mar 1, 2013
    Last edited: Mar 1, 2013

    one1 thread starter macrumors 65816

    Joined:
    Jun 17, 2007
    Location:
    Chattanooga, TN
    #7
    Unless both machines are identical running the same OS and having the same issue. Meaning only one is really having an issue. http://forums.macrumors.com/showthread.php?t=1319188


    Thanks for the responses folks, I'll look into the suggestions in a bit when I get spare time tonight. :)
     
  8. one1 thread starter macrumors 65816

    Joined:
    Jun 17, 2007
    Location:
    Chattanooga, TN
    #8
    This seems to have worked!

    http://www.youtube.com/watch?v=DHCBRsSvFwA

    Will give it a day or two and see for sure, but has certainly made the difference in short term wake from sleep. Theoretically should be fixed as that was the issue. :) We'll see!
     
  9. BillyBobBongo macrumors 68020

    BillyBobBongo

    Joined:
    Jun 21, 2007
    Location:
    On The Interweb Thingy!
    #9
    Will have to give it a try myself. I've had the same problem since Lion was released.

    Normally I just go in to 'Airport' and reboot my router to get the connection to come back. What's odd is that not all computers in the house loose the connection at the same time...and my iPhone and iPad have never dropped the connection.
     
  10. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #10
    "I'd never use a stationary computer in WiFi, wired Ethernet is just so much faster & stabler."

    Second this opinion.

    If the iMacs in question are -anywhere- near the router, string some Ethernet cabling and be done with it...
     
  11. one1 thread starter macrumors 65816

    Joined:
    Jun 17, 2007
    Location:
    Chattanooga, TN
    #11
    Billy this has WORKED perfectly. Finally a solution after all the others failed. I've done every silly suggestion out there from reorganizing the network connections in preferences, to deleting everything with the word airport or network in it in the library and all of them failed to allow my mac to reconnect after sleep. The very first time it slept I had to choose the network to set it back into a habit of connecting to that network, but not since! It's so great to finally have a working Wifi after dealing with this for the entire release of Lion and now Mountain Lion.

    It seems that when you give it keychain access by manually connecting it each time you are doing what it cannot do after sleep which is access the keychain. The reason why it cannot access the keychain seems to be with the way it reads that keychain that was created in Snow Leopard and upgraded to Lion or Mountain Lion. Even when you do a fresh install of MT Lion it carries over many of the preference files and deletes the rest of the pics and accounts, I've noticed.

    By deleting this keychain and creating a new one in Mt Lion it makes one specifically for Mt Lion and WORKS finally. :) YAAAYYY. :apple:
     

Share This Page