Convert to xCode 10.1 swift 4.0

Discussion in 'iOS Programming' started by rich1812, Nov 3, 2018.

  1. rich1812 macrumors member

    Joined:
    Oct 4, 2015
    Location:
    earth
    #1
    Hello, I downloaded a xCode project, I believe it was done in xcode 8.x. Swift 2.x.. I opened it in the latest xCode 10.1. When I open the project, I had a bunch errors and warnings. I managed to fix them except 2 errors, -

    Showing All Messages

    Build system information

    error: Value for SWIFT_VERSION cannot be empty.

    How can I fix this? Thanks.
     
  2. Mark FX macrumors regular

    Mark FX

    Joined:
    Nov 18, 2011
    Location:
    West Sussex, UK
    #2
    Go to the Projects or Targets Build Settings.
    Scroll down to "Swift Compiler - Language" setting
    And then select the Swift Language Version your Project or Target is using.

    I believe you can have "Unspecified" Selected for the Project setting.
    But must select a Swift Version number for the Target.

    Make sure your code source files contain the Swift syntax that matches your Language Version Setting.

    Regards Mark
     
  3. rich1812 thread starter macrumors member

    Joined:
    Oct 4, 2015
    Location:
    earth
    #3
    "Go to the Projects or Targets Build Settings."
    Where is this Projects or Targets Build Settings?attached is an image of the project, I don't see anywhere to change the swift version.
     

    Attached Files:

Share This Page