Converting Canon 550d footage for FCE + FCE settings

Discussion in 'Digital Video' started by RobbieSea, Oct 17, 2012.

  1. RobbieSea macrumors newbie

    Oct 17, 2012
    Hey everyone

    Straight to the point, I'm making a music video in Final Cut Express & the deadline for it is nearing. The video was shot on a Canon 550d w/ class 10 32GB Extreme HD Video SD card. I put all the footage into a folder on my desktop via card reader then from there I imported it into FCE.

    Here are the shooting details according to QT Movie Inspector:

    Canon 550d
    H.264, 1920 x 1080, Millions
Linear PCM, 16 bit little-endian signed integer, 2 channels, 48000 Hz
    FPS: 25
    Data Rate: 44.88 Mbit/s
    Date Size: 344.7 MB
    Current Size: 1440 x 810 pixels

    I exported a small clip from FCE as a test because I was wondering about whether I had the settings correct.* I obviously had something wrong because it was coming out with weird lines all over the place. Have a look at that HERE.

    So anyways I started researching after the test clip came out terribly & have learnt that I've foolishly been editing the footage in its h.264 format in FCE, which requires constant rendering & is highly stressful!
    So I downloaded MPEG Streamclip to convert my footage. From what I've read, ProRes is the best format to go with, however it doesnt work with Final Cut Express (correct me if im wrong!) so I have to use Apple Intermediate Codec.

    Heres how I've got the settings in MPEG Streamclip:

    Compression: Apple Intermediate Codec
    Quality: 100%
    Frame Size: 1920 x 1080 (unscaled)
    Frame Rate: 25
    Frame Blending: OFF
    Interlaced Scaling: OFF
    Deinterlace Video: OFF

    These settings seem to match those that I shot with.

    So next I would import all my footage into FCE. Now here Im not sure what settings I need to have in 'Easy Setup'. Here are my current settings:

    Format: Apple Intermediate Codec
    Rate: 25.00 FPS
    Use: HDV-Apple Intermediate Codec 1080i50

    Is this right?? Am I missing something somewhere?!

    Also when exporting videos out of FCE, I've always done File>Export>Using QT Conversion>Options:

    Compression: H.264
    Quality: High
    Frame reordering: Yes
    Encoding Mode: multi-pass
    Dimensions: 1920x1080

    I've since read that it is not wise to use the conversion option, but again, i dont really know.

    I pulled a clip into FCE that I had converted using MPEG Streamclip so i could test it. I put some keyframing on it & exported it to see if the same lines appeared when the image moved across the screen, and they did. So frustrating! It doesn't seem to be too bad until screens start moving around etc.

    If anyone could help me out & let me know what settings ive got wrong, why the clips have these lines through them, & how i can stop it, that would be great! Any help is massively appreciated!

    Im an amateur as Im sure you've guessed, so my apologies if im doing something stupid without realising!

    Thanks for reading!
  2. simsaladimbamba

    Nov 28, 2010
    Those are INTERLACING lines, because you set your project to 1080i50. I do not use FCE, thus I do not know, if there is a 1080p25 project/timeline setting, but you should take a look at that, as your footage is PROGRESSIVE (1080p) using 25 frames per second (1080p25).
  3. RobbieSea thread starter macrumors newbie

    Oct 17, 2012

    Ahhh cool. Now I understand the difference between the 'i' & the 'p' ! It turns out that Final Cut Express doesnt support 1080p, so im trying to locate Final Cut Pro 7 so i can continue with the video.

    Thanks for the reply dude :)
  4. npaisnel macrumors member

    Jun 23, 2013
    I have almost the same issue. Canon Camera, (5D 3) , FCE 4.0.1
    Easy Setup Apple Intermediate Codec AVCHD 1920 1080i50 at 25fps

    What settings should I use as an output from MPEG Stream Clip to make the footage compatible with the above FCE Easy Setup?

    There are 3 different 1920x180 radio buttons plus the two Interlacing check boxes, plus the Frame Blending and Better downscaling options.

    too many different options to try them all to get it correct by trial and error alone.



    Attached Files:

Share This Page