Cookies don't "stick"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by eturner, Feb 24, 2008.

  1. eturner macrumors newbie

    Joined:
    Feb 24, 2008
    #1
    Since I upgraded to 1.1.3 (unlocked) last month, I've had a problem with sites like Facebook or Gmail--after I log in, I get logged out after viewing one or two pages. The cycle repeats infinitely.

    I've set Accept Cookies to "Always." I've also cleared the cookies and cache repeatedly.

    My problem seems similar to the one being described on this thread, but I thought I'd make a new thread to open the problem to people who aren't necessarily using Hotmail:
    http://forums.macrumors.com/showthread.php?t=438188&highlight=iphone+cookies

    Any ideas? Is anyone else having this problem on Facebook, Gmail, or other sites?
     
  2. simoleon macrumors newbie

    Joined:
    Jan 11, 2008
    #2
    Are you using the iPhone specific Facebook site? Also, do you view your gmail account through Safari or using the Mail app? I've had problems with Facebook if I use the non-dedicated site (I don't know if that's even possible anymore) and sometimes if I'm checking my gmail account through safari. Both dedicated routes work fine for me though.
     
  3. eturner thread starter macrumors newbie

    Joined:
    Feb 24, 2008
    #3
    The problem isn't specific to Facebook; I just used that as an example. The problem occurs on any site to which I have to log in.

    My Mail app works fine.

    ...so no one else is having this problem where the browser forgets/ignores cookies?
     
  4. sva macrumors regular

    Joined:
    Oct 8, 2007
    Location:
    Wales, near England.
    #4
    I'm getting the same problem. I get to view a few pages on facebook before it asks me to log in again, it's highly annoying.

    I'm on 1.1.3 jailbroken and unlocked. I was hoping updating to 1.1.4 would solve it.

    Edit: just tried macrumors forums on the iPhone and I get the same, so it doesn't look like a facebook issue. I've not tried any other sites.
     
  5. nermal0 macrumors regular

    Joined:
    May 31, 2006
    Location:
    Germany
    #5
    Same problem here, didn't see the issue on 1.1.3, but 1.1.4 definitely has it.
     
  6. sva macrumors regular

    Joined:
    Oct 8, 2007
    Location:
    Wales, near England.
    #6
    Yup, I've just upgraded to 1.1.4 and it's still there.

    Are we the only ones then? Is it a jailbreaking issue?
     
  7. Pattycerts macrumors 6502

    Joined:
    Jul 4, 2007
    #7
    I have 1.1.4 and also have this issue, Matter of fact, none of my cookies are holding, and I have to log in again everywhere I visit. Very annoying. Anyone?
     
  8. yetanotherdave macrumors 68000

    yetanotherdave

    Joined:
    Apr 27, 2007
    Location:
    Bristol, England
    #9
    Same here, only noticed it on livejournal though.
    (Jailbroken 1.1.3 16Gb touch)
     
  9. sva macrumors regular

    Joined:
    Oct 8, 2007
    Location:
    Wales, near England.
    #10
    A guy on the Apple forum has found a solution to the problem.

    The solution is to restore your iPhone to factory and not to use your old backup when iTunes gives you the option. It worked for me, although it did mean that I lost all my SMS and camera roll photos :(.
     
  10. yetanotherdave macrumors 68000

    yetanotherdave

    Joined:
    Apr 27, 2007
    Location:
    Bristol, England
    #11
    There's work arounds and solutions. That's a work around. I think we'd all prefer a solution, which will exlain why this is happening in the first place and stop it happening again.
     
  11. pivotal macrumors newbie

    Joined:
    Mar 15, 2008
    #12
    Hey guys, I've solved this one, but you need a jailbroken phone, otherwise you're waiting for a fix from Apple. :D

    Short story: permissions on /var/mobile/Library/Cookies is wrong (or assigned to the wrong user).

    Long story and full explanation on my site.
     

Share This Page