Copied files to external HDD, now they are not there.

Discussion in 'macOS' started by RichardF, Dec 31, 2007.

  1. RichardF macrumors 6502a

    RichardF

    Joined:
    Oct 27, 2006
    Location:
    New York City
    #1
    While working in iMovie and importing footage from my mini DV camcorder, I ran out of space on my MBP so I quit iMovie, I copied the entire iMovie Events folder to an external firewire HDD via a drag in Finder this morning, saw the copy complete, deleted the files within the original me > Movies> iMovie Events folder on my MBP to make space (emptied the Trash) and launched iMovie, kept on importing the remainder of the footage, quit iMovie, then did nothing on the computer and/ or the HDD since then but this evening after checking on the HDD, I see the files are not there.

    What gives? Anyone's seen this? I had read about Mac OS 10.5.1 losing data when moving files but in my case my understanding is that I copied not moved the files, so I am not sure this the same problem.
     
  2. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #2
    I believe that is a 10.5.0 problem, not a 10.5.1 problem. Are you sure you copied the files? Dragging to an external only creates and alias and does not in fact copy. You have to command drag for that (I think it is command).
     
  3. skinnylegs macrumors 65816

    skinnylegs

    Joined:
    May 8, 2006
    Location:
    San Diego
    #3
    Not true.....

    Dragging a file to an external HD makes a copy; not an alias. I do it every day.
     
  4. skinnylegs macrumors 65816

    skinnylegs

    Joined:
    May 8, 2006
    Location:
    San Diego
    #4
    When you dragged the file over, did you see a small window pop up similar to the one in my screenshot?

    [​IMG]
     
  5. RichardF thread starter macrumors 6502a

    RichardF

    Joined:
    Oct 27, 2006
    Location:
    New York City
    #5

    Yes I did and it took 20 mns but it completed (copied about 35GB)

    My understanding is that the default behavior in Finder is to Copy not Move files (I didn't press the command Key before/ while dragging the files), in particular when it comes to external volumes.


    I appreciate the help guys.
     
  6. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #6
    Oh yeah, that only happens if you're copying to a cd you're going to burn.
     
  7. skinnylegs macrumors 65816

    skinnylegs

    Joined:
    May 8, 2006
    Location:
    San Diego
    #7
    Unfortunately I don't have an explanation other than it was one of those weird things. Have you tried copying something else and, if so, did you get similar results?
     
  8. RichardF thread starter macrumors 6502a

    RichardF

    Joined:
    Oct 27, 2006
    Location:
    New York City
    #8


    Doing it now to test.

    This sucks. I don't know what went wrong. I hate when things go wrong.
     
  9. skinnylegs macrumors 65816

    skinnylegs

    Joined:
    May 8, 2006
    Location:
    San Diego
    #9
    I would try a couple of smaller files and see what happens.
     
  10. skinnylegs macrumors 65816

    skinnylegs

    Joined:
    May 8, 2006
    Location:
    San Diego
    #10
    Just for the heck of it, you might also want to eject your external HD then remount it and see if anything shows up.
     
  11. RichardF thread starter macrumors 6502a

    RichardF

    Joined:
    Oct 27, 2006
    Location:
    New York City
    #11

    Yep, did that. I was hoping they'd show-up but no such luck.
     
  12. RichardF thread starter macrumors 6502a

    RichardF

    Joined:
    Oct 27, 2006
    Location:
    New York City
    #12


    Yep, this time, the files are there after it finished copying. This morning I didn't actually check the HDD to see whether the files were actually on the HDD. I just picked-up a healthy habit: I will always check from now on.
     
  13. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #13
    Ah, well they might have errored out. Always check before deleting.
     
  14. RichardF thread starter macrumors 6502a

    RichardF

    Joined:
    Oct 27, 2006
    Location:
    New York City
    #14
    Yes, indeed.

    What's odd is that the iMovie Events folder on the external HDD shows 91 items while my original one only 43. Yet if I double-click the one containing "91" only the same 43 are actually visible.


    So they are there but just not visible?
     
  15. skinnylegs macrumors 65816

    skinnylegs

    Joined:
    May 8, 2006
    Location:
    San Diego
    #15
    Sorry to hear you lost files but glad to hear you seem to have come to some resolution.
     
  16. RichardF thread starter macrumors 6502a

    RichardF

    Joined:
    Oct 27, 2006
    Location:
    New York City
    #16

    Thank you for your help.
     

Share This Page