Coprocessor and SM Bus Controller drivers for Windows 7 32bit Issue

Discussion in 'Windows, Linux & Others on the Mac' started by jimthegreek, Jan 14, 2009.

  1. jimthegreek macrumors member

    Nov 20, 2008
    Is anyone else having issues getting the drivers for these two items to load?

    I can't figure out what exactly its looking for.

    Any help would be much appreciated.

    btw, im using a unibody macbook pro
  2. taskmaxter macrumors newbie

    Feb 4, 2007
    Yes, same issue. I was somehow able to get troubleshooter to reload the SM Bus Controller, but I have not been successful on the CO Processor.
  3. jimthegreek thread starter macrumors member

    Nov 20, 2008
    Hopefully someone can chime in with some help
  4. Alexkiddo macrumors newbie

    Jan 14, 2009
    hello to all the forum,

    this is my first post here :D

    I could successfully install Coprocessor and SM Bus Controller by extracting the following drivers from the original drivers located in the instalation Leopard DVD Drivers\NVidia\Nvidia.exe :

    SM Bus Controller: SMBus
    Coprocessor: SMU

    to extract to a folder is possible by using WinRar

    let me know if it worked for you as well

  5. tankalf macrumors newbie

    Jan 15, 2009
    Hello to EVERYBODY !!

    This is my first post in this wonderul forum, also for me :D :D

    I installed WIndows 7 in my new unibody MBP 15", all fine. I had only two question points in Coprocessor and SM Bus.

    So I follow instructions, and I installed manually nvidia drivers from boot camp drivers coming with MBP.
    Questions points there aren't now, but Windows performance index (disk data transfer rate) is again very low, only 2.9 !!

    I read many people have solved problem, with a 5 - 6 points.

    How can we do?

    All performance indexes are higher than Vista, but not the disk data transfer rate.

    I hope you can help us...

  6. andimaciphone macrumors member


    May 9, 2008
    I had this issue too but solved it.

    Hi all,

    I too had the same issue and resolved it by installing two Nvidia packages from my Leopard disk.

    On the Leopard disk in the bootcamp directory there is drivers directory.

    One of these directories is called Nvidia, I installed two of the apps from here.

    Can't remember which ones off the top of my head as i am at work.

    But from memory there are only 2 that are not either 64 bit or for windows xp.

    Once these drivers were installed the yellow triangles disappeared and I was able to get a Windows Experience Score.

    Hope this helps.:)
  7. tankalf macrumors newbie

    Jan 15, 2009

    Thanks for your help, I also do this and yellow flags disappeared.

    But experience index was too slow

    So I just read a solution, and it works !! ;)

    In device manager, select properties in your disk drive, and in Policies tab, leave off "Enable write caching..."

    Do again your windows experience index test, and magically you can obtain a very high result in disk data transfer rate !! Now I have 5.9 from 2.9 !!!

    Now, it's better to leave it off or to enable it again ??

    I will do some tests...
  8. olifante macrumors newbie

    Feb 8, 2009
    Alternative workaround for Aluminum MacBook

    Thanks for the hint, Alex. I had to use a variation to solve the SM bus and coprocessor driver problems:

    I installed Windows 7 (32-bit edition) in my Aluminum MacBook with no problems, but couldn't get the Boot Camp drivers to install - I always got an uninformative error 2229. After reading Apple's forums I changed the Location to "US" and the Format to "English (United States)" and the Boot Camp drivers now installed without problems.

    I upgraded Boot Camp to 2.1 and installed the Multi-Touch Trackpad update but I then found out that there were still driver problems with the SM bus and the coprocessor. A google search quickly brought me to this forum. I tried locating the NVidia.exe that you mentioned in the Leopard DVD, but only found these files:


    Trying to install any of these resulted in the following error message:

    "The NVIDIA Setup program could not locate any drivers that are compatible with your current hardware. Setup will now exit."

    Fortunately success was around the corner. Since I had previously found out that I couldn't use my original copy of Leopard to install OS X in my MacBook, I tried the Mac OS X Install DVD that came with my Aluminum MacBook, and found out that it comes with different files. Running this installer solved my SM bus and Coprocessor driver problems:

    D:\Boot Camp\Drivers\NVidia\NVidiaChipset.exe

    As far as I can tell, the only thing that's not yet working for me is the mapping of the MacBook function keys row to the standard Apple operations (brightness control, volume control, etc.)
  9. olifante macrumors newbie

    Feb 8, 2009
    Write Caching Off => disk WEI rises from 3.0 to 5.4

    Thanks for the tip!

    I followed your advice, and the WEI for my Aluminum MacBook's primary hard disk rose from 3.0 to 5.4. A bit strange, considering that Write Caching is supposed to enhance performance.

    My overall WEI is now 4.5, with the Gaming Graphics performance being the lowest common denominator.
  10. BlackLight macrumors regular


    Nov 21, 2008
    thanks that solved my problem ..hope others experience same result
  11. olifante macrumors newbie

    Feb 8, 2009
    I replaced my 32-bit install with the 64-bit version of Windows 7 works in my Aluminum MacBook. To get everything working, perform the following steps:

    1. Start Boot Camp assistant from Leopard, insert the Windows 7 x64 DVD and reboot.
    2. Follow the standard procedure for installing Vista, taking care to leave the Location and Region unchanged as "US" and "English (United States)".
    3. When you boot into Windows 7 for the 1st time, insert the 1st of 2 DVDs that came with your MacBook, the one labeled Mac OS X Installation disk. It comes with the Boot Camp 2.1 drivers, but normal installation fails with Windows 7 x64. Do a manual installation by double-clicing the Boot Camp x64 installer:
      D:\Boot Camp\Drivers\Apple\BootCamp64.msi
    4. Reboot and most things will be working, except for the SM Bus and Coprocessor driver problems discussed in this thread. The solution is simple. Run this file:
      D:\Boot Camp\Drivers\NVidia\NVidiaChipset64.exe
      When it asks you which features you want to install, you only the "NVIDIA SMBus Driver" and "NVIDIA SMU Driver" need to be selected. After installation, navigating to the "Drivers and Printers" panel should show you that the Exclamation Sign is no longer displayed on your computer without even having to reboot.
    5. The original Boot Camp driver for the MacBook's Multi-Touch Trackpad is quite buggy. As a final step, upgrade to the latest version.

    After performing these steps, everything seems to be working for me, including the function button row. I got an overall Windows Experience Index score of 4.4, determined by the Gaming Graphics sub-score.

    The "Disk data transfer rate" determined by the Windows Experience Index was 5.4, and I didn't have to disable Write Caching as described above to get this result.

    Hope this summary helps!
  12. 8Limes macrumors newbie

    Sep 27, 2008
    32 & 64 bit on unibody macbook pro

    For the windows 7 32 bit version you need is to install the driver for the SM bus and Coprocessor after the regular bootcamp installation from the Mac OS X Installation Disk.

    D:\Boot Camp\Drivers\NVidia\NVidiaChipset.exe

    For the windows 7 64 bit version you need to manually execute the bootcamp installation from the Mac OS X Installation Disk.

    D:\Boot Camp\Drivers\Apple\BootCamp64.msi

    For the SM bus Controller and Coprocessor.

    D:\Boot Camp\Drivers\NVidia\NVidiaChipset64.exe

    The only problem i have right now is that the installation disk won't eject. not in computer by clicking eject or by clicking the eject button on the keyboard. all i get is:

    An error occured while ejecting 'DVD RW Drive (D:) WindowsSupport'

    the smiley was not there before, but the forum doesn't know better.

    I will try after the reboot the trackpad update requires to eject the DVD. I think this is only a fluke, but if not i will let you know. Everything else works great so far. My keyboard buttons like volume, brightness etc work fine as well. just not the eject button at the moment as mentioned before. l8
  13. 8Limes macrumors newbie

    Sep 27, 2008
    DVD Installation Disk

    It just won't release the DVD. Even after a reboot. Everything else works fine. Another reboot, go in select mode with the option key, eject dvd, back into windows 7 and another try with another dvd. hopefully just a single case, i am slowly getting worried.
  14. 8Limes macrumors newbie

    Sep 27, 2008
    Just a fluke, no worry.

    I put in Bobby (Movie DVD) after the reboot, set up the media player settings quick, and the movie started right away playing. Closed media player, ejected bobby, tried the install dvd again. ejected as well. i didn't bother trying to unzip a .rar file or even let the autoplay start though, so i am not a 100% certain. :rolleyes:
  15. iluvmacbookpro macrumors newbie

    Sep 29, 2009
    this worked for me.

    I have latest Macbook Pro aluminum with SSD, and Snow Leopard and Windows 7 RTM with latest bootcamp.

    I grabbed my OS X install disk from the box (10.6 SL does not have bootcamp drivers in any accessible folder that I could find), installed the Nvidia 64 bit drivers. It completed without error. The processor yellow bang went away (that was my only yellow flag).

    I reran the Experience Index and all scores were higher... now ranging from 6.0 to 6.3. I did not have to tweak the hard drive settings per previous posts.

    I did have the problem where I could not eject the disc. I booted up again in Mac OS, ejected disk, rebooted in Windows 7, and installed multi touch update and now I can eject the disk. Go figure. Anyway, good news is that this 64 bit NVDA driver does make things go faster... which is nice.
  16. gunnagirl macrumors newbie

    Nov 1, 2009
    Thanks very much guys! You helped me, so simple! bootcamp acted like it installed my drivers fine but i soon found no aero (due to not recognising my nvidia vidoe card) and THEN no processors recognised! All okay now, did exactly what you guys recommended about the bus controllers from a 32bit point of view :)
  17. dbenchimol macrumors newbie

    May 17, 2010
    Coprocessor Driver

    The driver you are looking for is located in the following location on the OS X install disk. This will solve your problem easily, if you use the windows hardware installer.

    E:\Boot Camp\Drivers\NVidia\NVidiaChipsetXP\SMU
  18. jadoue macrumors newbie

    Mar 17, 2013
    smc bs controller and coprocessor

    Hi guys
    I had the same problems, just insert the application install dvd or the backup driver and ask the pc to search for it on the DVD, it will do the job in 5 minutes
    good luck
  19. Vegerot macrumors member


    May 14, 2009
    Baltimore, Maryland
    I have long since lost my OS X Installation CDs. Can somebody give me a link to either the drivers or the installer app?

    I tried downloading Apple's Windows Support Software and trying the same thing. I went to Drivers>NVIDIA but there was nothing called nvidiachipset64.exe, nvidia.exe, or anything.
  20. chrfr macrumors 604

    Jul 11, 2009
    What model Mac do you have?

Share This Page