Copy (and paste) does not work!

Discussion in 'Mac Basics and Help' started by drummer22, Feb 21, 2009.

  1. drummer22 macrumors newbie

    Joined:
    Feb 21, 2009
    #1
    I have had my 15" macbook pro for about 6 months now. Amazing labtop...

    Now i have learned almost all of the keyboard shortcuts and use them very frequently. The main ones I use are obviously :apple: + C followed by :apple: + V . However, recently my :apple: + C refuses to work! To copy something I have to manually go into the edit menu and select copy. Yet, all of my other keyboard shortcuts, including :apple: + V continue to work!

    I don't understand. How do I fix this? Keep in mind, this has been going on for about a week so the computer has been turned on and off many times.

    Thanks
     
  2. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #2
    Specific application or all of them?

    Try making a new User Account and see if the problem persists.
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    It's possible you or a recent installed program has tried to assign something to that keyboard combination. Install anything recently?
     
  4. drummer22 thread starter macrumors newbie

    Joined:
    Feb 21, 2009
    #4
    Well I installed a demo of Kaleidagraph. I dont think that was when the problem started. Although, when I was setting up my "Spaces" I was trying to get it where instead of pressing fn + f"X", it would be :apple: + f"X". Come to think of it, thats seems to be when the problem started. But right now my spaces are activated by fn + f1.

    It is in all applications. Word, Safari, etc...

    Its so weird because even in the edit menu it says the shortcut is :apple: + C.
     
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #5
    See if going to the System Preferences/Keyboard & Mouse and pressing the "Restore System Defaults" button under Keyboard Shortcuts works.
     
  6. drummer22 thread starter macrumors newbie

    Joined:
    Feb 21, 2009
    #6
    Already tried it and just tried it again... Still doesnt work. Any other ideas. This makes absolutely no sense
     
  7. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
  8. olliea95 macrumors regular

    olliea95

    Joined:
    Feb 10, 2009
    Location:
    Surrey, UK
    #8
    Try what Kilamite has said, it maybe something is trying to use the same shortcut. If it works in a new account, then you know one of your recently installed programs is being an uncooperative sod.
     
  9. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #9
    Have you tried turning off Spaces to see if that helps?
     
  10. drummer22 thread starter macrumors newbie

    Joined:
    Feb 21, 2009
    #10
    I did turn off spaces and that did not help.

    Ok. I set up a new user account and now the shortcut works. So what does this mean? I dont understand why Kaleidagraph would change the settings when it even says that its shortcut for Copy is :apple: + C.

    Also, I am afraid to just uninstall it as it is only a demo that I have for only 40 more days. And I need it for one of my classes.
     
  11. drummer22 thread starter macrumors newbie

    Joined:
    Feb 21, 2009
    #11
    I looked in the shortcuts for KaleidaGraph and their copy shortcut is also :apple: + C. Yet, it does not work in KaleidaGraph either!
     
  12. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #12
    Find where your preferences are, all the .plist files.

    Make a new folder on the desktop.

    Take half the preferences, and move them to the folder on the desktop.

    Log out and log back in to see if the problem is still there.

    Swap files around and log in/out to see if the problem comes back.

    By the file names, and chopping the possible culprits down by moving them out of the pref folder ... you may find the problem preference file.

    If you find it, you can go in and change the settings for that file through the applications -- or trash the file and start over.

    ---

    Also could be a login item that is doing it so turning them off before trying the above might work also.

    NOTE: trashing all the preferences is a pain ... since you have to reset all your preferences by hand again. So narrowing things down does help.
     
  13. drummer22 thread starter macrumors newbie

    Joined:
    Feb 21, 2009
    #13
    Great advice! Thanks. Yeah turned out it was a preference for speech reading. So if I held down :apple: + C for like 5 seconds, it would finally copy the material, but also start reading it.. ha Thanks for the help!
     
  14. carfac macrumors 65816

    carfac

    Joined:
    Feb 18, 2006
    #14
    >>> Copy (and paste) does not work!

    Sounds like you have an iPhone :D

    (Sorry, I could not resist! :p)
     
  15. rehak69 macrumors newbie

    Joined:
    Feb 6, 2009
    #15
    how bizarre i just had this same exact problem.. except when i cmd+c, my voice would sing it to me. hhhhttttttttpppppp semmmicolon back slash back slashhhhhh.

    total flaw..

    just thought i'd say thanks.
     

Share This Page