Copy/Cut Whooshing Sound

Discussion in 'macOS' started by billding, Apr 6, 2017.

  1. billding macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #1
    Hi All...I get a strange whooshing sound that only occurs when I copy or cut something (command-c or command-x). I cannot for the life of me, get to the bottom of it—it just started happening in the last year or so, perhaps when I upgraded to Yosemite (happens on Sierra as well), but I don't think it started right away?? I would love to get rid of it, as I am working on music out of monitor speakers and going back and forth muting all the time is a pain—but not as big a pain as that sound blasting out of my speakers!

    thx much for any ideas..
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    Check your Sound preference:
    System Preferences...>Sound>Sound Effects and make sure "Play user interface sound effects" is NOT checked.
    System Preferences001.jpg
     
  3. billding thread starter macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #3
    Hi, thanks, but it's not checked. And wherever that sound resides, it's not any of the sounds found in "sound effects."
     
  4. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    If it is a system sound/interface sound effect, then turning down the Alert volume would put that under control.
    If it is affected by the Output volume, too, then you can adjust the Alert volume according to that.
    If you don't want to hear alert sounds at all, then turn that Alert volume all the way down.

    If that copy sound is not affected by the alert volume setting, then it is something else that you have installed that provides that sound, not the system.

    Do you have Soundflower installed? Or some other audio "enhancement" software, Boom, etc?
     
  5. billding thread starter macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #5
    Hi, I do have Soundflower & Jack on my laptop (2015 MacBook Pro). But they're not active—they don't show up in my list of routing options in my preferences. I'm also not using the system audio—I have a Metric Halo 2882 audio interface/software. But the whooshing sound occurs whether I'm using that or the system audio, and again, only when I'm copying or cutting...

    Any further thoughts?

    thx
     
  6. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    So, adjusting the Alert volume in the Sound pref pane does not affect the volume of the copy/cut sounds that you hear?

    Unless you have somehow changed the system code, or removed/modified relevant kexts, using other audio control software does not bypass the system audio, does it? (That is, you would still get alert sounds from the system)

    Have you tried directing the alert sounds somewhere else, using the Sound pref pane/play sound effects through: then choose an output that is NOT your monitor speakers. For example, you would be using the audio through Firewire for your 2882, correct? Then sending alert sounds to headphones (leave headphones disconnected, or plug an old set just for this test) should go to the headphone output. You don't use that with your audio gear, correct?

    If that doesn't help, and you expect the 2882 to bypass all audio in the system, including alerts, maybe you could ask at the MH forums, or try a support request directly to Metric Halo.
     
  7. billding thread starter macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #7
    Hi, no, the alert volume in the pref pane is fully muted. Also, the sound isn't one of the sound fx in the default list (basso, blow, bottle, frog, etc). This whooshing sound only occurs when I copy or cut...in other words, I guess, when I add something to the clipboard. No other key commands—command-f/g/i/v/etc trigger the sound. Also, it doesn't seem to have anything to do with the Metric Halo interface. I've been using it since 2006 without this sound occurring. Also, the sound occurs even when I choose the default core audio sound.

    thx
    D
    --- Post Merged, Apr 7, 2017 ---
    Also, if this makes a difference, the sound doesn't occur merely by pressing command-c or x. I have to actually be adding something to the clipboard for the whoosh to occur.
     
  8. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    hmm... (random thoughts now :D )
    I don't think I have ever heard a copy or cut command cause a sound on the Mac - ever.
    Actual copy - moving or copying to another folder or drive, yes. Clipboard actions, no...
    So, no other actions (as far as you know) trigger those sounds, other than copy or cut? Does "paste" make any kind of noise?
    The "woosh" that you hear makes me think of the normal sound effect that the system provides when dragging an item to the trash. That sound would NOT be one of sounds listed in the Alerts list, and is purely internal, used for finder sound effects, and should be controlled through the Sound pref pane.
    Do you have a clipboard manager of some kind installed? Maybe as one of the programmed features of some audio software that you use?

    Try this: toggle the "Play user interface sound effects". On, then try your copy or cut.
    Then turn that setting off, and try the copy or cut again.

    Have you heard anything from Metric Halo support? COULD be something that has basically changed in the macOS system in the last version or two.
     
  9. billding thread starter macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #9
    Hmmm....well, I just toggled "Play user interface sound effects" and then I also switched the "Play sound effects through" from Internal Speakers to my Metric Halo and back and the sound is gone!! Dunno why, but I guess it jostled something that was stuck?

    THANKS!!
     
  10. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #10
    Yep. You accidentally fixed it. I don't know how many times I have seen toggling features off, then on (or the opposite) fix issues. I like to think of it as your system gets a little "rusty" in the cracks of the system, and toggling a few software features that might be connected, can get everything cleared up again - until next time.

    Good to hear that fixes things for you.
    I guess you will find out if you hear that sound again. Of course, the way this all works, the same fix won't help you next time :D
    Here's hoping that "next time" won't happen for you...
     
  11. billding thread starter macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #11
    So great to have blessed silence again when copying/cutting something! That sound was driving me crazy...

    Thanks again for your suggestion...we'll see about next time—as the old saying goes, "generals are always fighting the last war." :)

    cheers
     
  12. MacGizmo macrumors 65816

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #12
    Cut, Copy nor Paste have never made a sound effect by default in the MacOS. Something you have installed is adding this feature in. That being the case, it won't matter what audio output you use, you're going to hear it if the volume is turned on/up.
     
  13. billding thread starter macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #13
    Hey All, in the name of clarity and for whomever this may happen to in the future, I discovered the true culprit. The fix I mention above above worked temporarily for some reason, but the sound always returned. If I went through the procedure I describe it stopped—then started up.

    The REAL culprit was a clipboard manager I use called iClip. I've been using this for many years, but, in fact, there in the preferences was an enabled option for a playing a sound when adding something to the clipboard—ostensibly only within the program, but somehow it happened wherever and whenever I did so. I simply turned it off (must've been on as a default with an updated version?) and have had four blissfully silent days without the whoosh..

    Thanks to all that weighed in—it all helped me track the problem down!
     
  14. billding, Apr 12, 2017
    Last edited: Apr 12, 2017

    billding thread starter macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #14
    I'm realizing it's gonna take a few days longer for the ghost of that sound to stop swooping into my head. I still "hear it" sometimes in my memory and I still brace for it. Guess I'm damaged :)
     
  15. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
  16. ngerasimatos macrumors newbie

    Joined:
    Oct 7, 2013
    #16
    Are you using any third party apps for your clipboard, such as Copia? I know some of them play sounds when you copy and paste. These can be disabled from within the app.
     
  17. billding thread starter macrumors newbie

    Joined:
    Apr 6, 2017
    Location:
    brooklyn
    #17
    HI, yes, I eventually figured it out—and, yes, you're right, I had downloaded a new version of iClip that had a c/p swoosh sound as default. Hate that stuff!

    Thx
    D
     

Share This Page