Copy data from broken disk

Discussion in 'OS X Mavericks (10.9)' started by sammy.d, Apr 2, 2014.

  1. sammy.d macrumors regular

    Joined:
    Jun 18, 2010
    #1
    Hi,
    I have a hard drive that contains a clone of my old hard drive (I recently put a new drive in my macbook) and I am trying to copy the last of the data from it. This last data is my video files and I am getting some errors with some of the files. When dragging certain video files from the disk to my hard drive, I receive an error that says:
    Code:
    The Finder can’t complete the operation because some data in “myvid.mp4” can’t be read or written.
    (Error code -36)
    This happens for some video files but not others in the same directory.

    So I tried to copy via Terminal (cp). The same files that I had trouble with before give an error there saying:
    Code:
    Input/output error
    I have tried repairing the disk in disk utility (it did find errors) but the same thing still happens afterwards.

    I can open and play the videos on the external drive with no issues so the video data still seems to be all there. Because there doesn't seem to be anything wrong with the actual file, is there a way I can copy it without having to use something like Data Rescue? I feel like if my computer can read the file to be able to play it, it should be able to read it to be able to copy it fine as well...
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    You could give CarbonCopyCloner (version 3.4.7 is still free and available for download here and works with Mac OS X 10.6 Snow Leopard, Mac OS X 10.7 Lion and OS X 10.8 Mountain Lion) and SuperDuper! a try.
     
  3. sammy.d, Apr 2, 2014
    Last edited: Apr 2, 2014

    sammy.d thread starter macrumors regular

    Joined:
    Jun 18, 2010
    #3
    So copy the broken disk to another drive?

    How is it possible that the data could be cloned if it isn't accessible? Is it possible to clone only part of a disk? I don't want everything else on there and finding another disk big enough might be a problem.

    I tried Data Rescue 3 on the disk and it started fine but quickly got to a point where it was giving me 'slow read time errors' that might make the disk fail if I continue...
     

Share This Page