Copying/Backup of Large iPhoto library fails

Discussion in 'Mac Basics and Help' started by aquaboy, Aug 19, 2013.

  1. aquaboy macrumors regular

    aquaboy

    Joined:
    Feb 17, 2011
    Location:
    UK
    #1
    Hi Eveyone.

    I wish to backup my iPhoto Library which is 55GB in size onto an external drive.
    But it is far to slow (12 days) then it fails after a few 100megs anyway.

    I've tried to backup onto a USB 3.0 64GB Memory Stick and onto my LaCie NAS Drive via Ethernet both with the same results. Slow and Error Fail to copy.

    I've also tried copying via Termainal cp -r but this also fails after a short period of time.

    I've read on google about this issue and it seems to be very common. I wondered if anyone had a easy solution that actually works.

    I'm on OSX 10.8.4 on new Late 2012 iMac.

    Thanks.
     
  2. samh macrumors 6502

    Joined:
    Oct 29, 2009
    #2
    What format are the external media using? A flavor of FAT or are they HFS?
     
  3. aquaboy thread starter macrumors regular

    aquaboy

    Joined:
    Feb 17, 2011
    Location:
    UK
    #3
    Hi, thanks for the reply.

    The USB Thumb Drive was in FAT32 so I re-formated it too Mac OS Extended (Journaled) and my iPhoto Library Copied Across fine and nice and quickly.

    My Setup for my storage drives is.....

    iMac ---- Ethernet too AppleTimeCapsule ---- Ethernet too LaCie 10TB Raid5 Drive(for iTunes) ---- and e-sata too LaCie 3TB Drive (for Backup)

    Hope that makes sense!

    I want to copy my iPhotos onto my 3TB Drive which is in MacOS Extended (Journaled) but it has to go via the LaCie 10TB Drive which isn't Mac Formatted. I think thats where the problem is.

    I'm gonna try and connect the 3TB Drive direct to the iMac and copy across that way.
    Lot of messing about really. Annoying bug! Fingers crossed.
     
  4. samh macrumors 6502

    Joined:
    Oct 29, 2009
    #4
    FAT32 does not support file sizes of 4 GB or more so that explains the problem with the thumb drive.
     
  5. aquaboy thread starter macrumors regular

    aquaboy

    Joined:
    Feb 17, 2011
    Location:
    UK
    #5
    Hi again, yes your correct, sorry my mistake, my thumb drive was in NTFS, not FAT32, and still failed to copy the file until I re-formated it into MacOS Extended (Journaled) format.....

    Anyway, I tried connecting my 3TB drive to my iMac directly, and Disk Utility said there was an error but couldn't repair it, without formatting it, and I don't want to format 3TB... the drive works fine, I think its more to do with the fact it's plugged into the 10TB drive and thats caused OSX to think it's got a problem.... Anyway, still stuck with how to back up my iPhoto's onto the drive. Grrrrrrr - at least its on my Thumb Drive ok for now. Just annoying I can't get it over to my 3TB Drive.
     
  6. AcesHigh87 macrumors 6502a

    AcesHigh87

    Joined:
    Jan 11, 2009
    Location:
    New Brunswick, Canada
    #6
    OS X can natively read but not write to NTFS. That was likely the issue.

    As far as your other issue. If you have the 10TB RAID, assuming there is space, why not temporarily put your 3TB files onto it, reformat the drive as OS X seems to want, and then move your files back including the iPhoto library? It's a longer process but should achieve the results you're looking for.
     

Share This Page