Copying entire hard drive errors?

Discussion in 'PowerPC Macs' started by applegeek13, Jul 21, 2010.

  1. applegeek13 macrumors regular

    Joined:
    Sep 7, 2009
    #1
    I have a powermac g4 fw800, and the hard drive is dying. I have a new one to replace it, I just want to copy all the files onto my replacement hard drive.

    Attempts 1-3: Disk Utility.
    I tried restoring the boot drive onto the new one, but it gave me an error. I forget exactly what it said. Anyways, it had copied most of the files, And I decided to give it a go. I set it to boot drive status, but it doesn't go past the grey apple screen on boot. I unplugged the drive, and booted up fine with my original. I'm not sure what happened in this case.

    Attempt 4: Straight-up copying.
    I tried just copying the disc onto my replacement drive. No luck. Apparently some files have special permissions restricting them from being copied, probably to prevent pirating. I gave up on this after that.

    So, what do I do now? Is there an app that will make the transfer for me, not Disk Utility? Or am I using DU incorrectly? Please help!

    Thanks!
     
  2. FourCandles macrumors 6502a

    Joined:
    Feb 10, 2009
    Location:
    England
    #2
    Have a look at Carbon Copy Cloner.

    The documentation and support will explain much better than I can, but basically you can use it to make a bootable copy (clone) of your current hard drive on to your new one. If your new drive is the same type as the old one in your Mac, you can then replace the old internal drive with the new and your Mac will recognise it as if it were the old drive.
     
  3. applegeek13 thread starter macrumors regular

    Joined:
    Sep 7, 2009

Share This Page