Copying Files To Disk Image VERY Slow?

Discussion in 'OS X Mountain Lion (10.8)' started by John55455, Aug 19, 2013.

  1. John55455 macrumors member

    Mar 17, 2012

    In Mountain Lion copying a folder containing only 15GB worth of files to a 128 AES encrypted sparse disk image takes over 24 hours!

    While I'd expert it to go a bit slower because it's encrypted I was surprised by how slow it went. So I tried all the different settings: sprase bundle, read/write, encrypted, all took about a day.

    I feel like it was a lot faster in Snow Lepord...?

    Can someone please explain why it takes 4 minutes to download a 1GB file, like 4 minutes to move a 15GB file, not much time to copy the 15GB to external HDD over USB 3.0, but 24 hours to copy files to something on the same physical, internal drive?

    I looked at CPU usage and the disk image related programs use like 4% max...? Is there any way I can ramp that up to 80% or something to speed this up?

    Like what is it doing that it takes 24 hours to copy 15 GB? Someone please explain this process...especially because it uses so little computer resources.

    So if I wanted to cooy 100GB to a disk image it would take over a week? Is this a Mountain Lion/Lion bug or glitch or do I just have the wrong settings.

    Thanks for your help. (Note: I need to copy these files to some kind of disk image I can't use any other format)
  2. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    Have you tried copying to an unencrypted sparse disk image just for a speed comparison?

    How is the disk the source file on attached to the computer? And the destination disk (if it is a different disk)?
  3. John55455 thread starter macrumors member

    Mar 17, 2012
    I tried all different combinations to find a fast one but they're all sloooooow.

    The source file is on the same single internal hard drive as the disk image. There shouldn't be any sort of third party bottleneck.
  4. mooblie macrumors 6502


    Apr 23, 2009
    The Highlands, Scotland
    Something's not right there, John.

    FWIW: I have a NAS, connected to my Mac mini (Snow Leopard) via Cat6-cabled gigabit ethernet.

    Writing/reading directly to the NAS from my mini I get Write=69 MB/s, Read=70 MB/s.

    Writing/reading to an unecrypted 100GB Disk Image created ON THE SAME DRIVE ON THE SAME NAS: I get Write=67 MB/s, Read=65 MB/s.

    I created that disk image as shown here:
  5. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    How full is the drive? If there's less than 10% free, you might want to see if there's junk you get rid of to get it to at least 10% free, but preferably 15% and see if that changes anything.

    If that isn't the issue, there is a chance that your hard drive could be having issues.

Share This Page