Coreaudio service keeps stopping. help?

Discussion in 'macOS' started by xgman, Jul 6, 2011.

  1. xgman, Jul 6, 2011
    Last edited: Jul 6, 2011

    xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #1
    My coreaudio service keeps randomly shutting itself off. I can enter a terminnal code to restart the service and restore my missing audio device list, but is there any way short of figuring out exactly what is causing this, to freeze this service so nothing can shut it down?

    I have done extensive troubleshooting and read the system logs and reinstalled the OS etc. I have some suspicion that it may be related to my firewire tcnear audio drivers doing something funky and unintentionally stopping the service, but I can't be sure. The logs are not specific enough to see exactly what is going on.

    I have resorted to placing the restart script in login items, since the service usually turns off upon startup. But sometimes it just turns off randomly during idle time if left sit long enough.

    Any ideas on workarounds to basically "lock" the service from turning off until I find the real culprit?
     
  2. Madd the Sane macrumors 6502

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #2
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Try looking for updated drivers?
     
  3. xgman, Jul 6, 2011
    Last edited: Jul 11, 2011

    xgman thread starter macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #3
    They are looking at the error but no new drivers yet. I am not 100% sure it is the TCnear firewire audio drivers. When I unplug the Firewire device and replug it back in it will dump all the audio devices on the spot including the internal ones. This is the log from that event and then the manual restart of coreaudio. The first part with all the callback references, is generated by opening up the audio section of system preferences before unplugging the firewire port:

    7/6/11 5:49:11.801 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for input device 112
    7/6/11 5:49:11.801 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for input device 108
    7/6/11 5:49:11.802 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for output device 101
    7/6/11 5:49:11.803 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for output device 92
    7/6/11 5:49:11.803 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for output device 88
    7/6/11 5:49:11.803 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for input device 76
    7/6/11 5:49:11.804 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for output device 76
    7/6/11 5:49:11.804 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for input device 37
    7/6/11 5:49:11.804 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for output device 37
    7/6/11 5:49:11.805 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for input device 33
    7/6/11 5:49:11.805 PM [0x0-0xad0ad].com.apple.systempreferences: Adding callbacks for output device 33
    7/6/11 5:50:39.000 PM kernel: TCNear: bus reset
    7/6/11 5:50:39.000 PM kernel: TCNear::processing RestartRequest
    7/6/11 5:50:40.000 PM kernel: TCNear::RestartStreaming (sr 44100, clksrc 12, opmode 1)
    7/6/11 5:50:40.000 PM kernel: TCNear: Resync (0)
    7/6/11 5:50:41.000 PM kernel: TCNear: bus reset
    7/6/11 5:50:41.000 PM kernel: TCNear::processing RestartRequest
    7/6/11 5:50:42.000 PM kernel: TCNear::RestartStreaming (sr 44100, clksrc 12, opmode 1)
    7/6/11 5:50:42.000 PM kernel: TCNear: Resync (0)
    7/6/11 5:50:51.000 PM kernel: TCNearAudio: TC Electronic KonnektLive guid:1660408c00207 connected.
    7/6/11 5:50:51.000 PM kernel: TCNear::processing RestartRequest
    7/6/11 5:50:52.000 PM kernel: TCNear::RestartStreaming (sr 44100, clksrc 12, opmode 1)
    7/6/11 5:50:52.000 PM kernel: TCNear: Resync (0)
    7/6/11 5:50:53.000 PM kernel: TCNear: bus reset
    7/6/11 5:50:53.000 PM kernel: TCNear::processing RestartRequest
    7/6/11 5:50:54.000 PM kernel: TCNear::RestartStreaming (sr 44100, clksrc 12, opmode 1)
    7/6/11 5:50:54.000 PM kernel: TCNear: Resync (0)
    7/6/11 5:51:03.000 PM kernel: IOHIDSystem: postEvent LLEventQueue overflow.

    By the way, this is the log below of what I enter in to terminal to restart the core audio to get the list of audio devices back in system preferences:

    7/6/11 5:59:43.621 PM sudo: root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/kill -9 5077
    7/6/11 5:59:43.632 PM com.apple.launchd: (com.apple.audio.coreaudiod[5077]) Exited: Killed: 9


    ediT:

    I removed all traces of the tcnear drivers and set the sound to internal and all the problems dissipated. I then did a clean install of the tcnear driver and all the problems of coreaudio shutting down returned immediately. Uninstalled again and back to normal. pretty clear that the tcnear drivers need some work. I may jump to the M-Audio 2626 and try their beta Lion drivers.
     

Share This Page