Coreduotemp doesn't update on Macbook 2.0GHz

mustgroove

macrumors regular
Original poster
Aug 14, 2006
198
11
I'm on my 5th Macbook, since my first 4 were all duds... It's technically the 6th machine I've had in my possession, since my Mac store lent me one while this machine was being built, but who's counting anyway... :)

So basically, I've noticed on this and last couple machines I had (before they died) that Coreduotemp works fine when it's run straight after a fresh install, and also after waking from sleep, but other than those times, the temperature readout doesn't update...

For example - I install Coreduotemp and run it, then I run MemtestOSX or the "yes >/dev/null" command and the temperature increases accordingly... But if I then restart the machine and run it again, the temperature that is displayed at first stays constant (or flickers between 2 temperatures neither of which ever changes) even when running MemtestOSX or the "yes >/dev/null" command, which of course must be raising the CPU temperature markedly...

The only times that it will update properly that I've noticed so far have been:

1) When Coreduotemp is already running, the program will start updating OK after waking up from sleep

2) It will update fine the first time you run it after installing it

Has anyone else noticed this behaviour? I can verify that this machine and at least 1 other have displayed this behaviour with Coreduotemp...

Does anyone know what it could be, and any possible workarounds? I've tried installing Speedit v0.5 instead of the v0.32 that is included in the Coreduotemp installer, but v0.5 caused some serious system instability...

Any help would be appreciated :)
 

NJuul

macrumors 6502
Mar 15, 2006
492
0
Boston
You should install the latest macbook firmware update (maybe smc firmware, don't remember), it should fix it.
I did it on a friends macbook that had the same problem, and then the temp monitors worked. It may be a big problem, because if the temp monitors doesn't function, the fan may not kick in to keep the CPU cool. Worst case scenario, you have a dead mac.
 

mustgroove

macrumors regular
Original poster
Aug 14, 2006
198
11
Yeh I do have the latest firmware installed... Obviously didn't fix it in my case :(