coregraphics framework causing permanent compile errors, can't texture map

Discussion in 'iOS Programming' started by Chirone, Sep 7, 2009.

  1. Chirone macrumors 6502

    Joined:
    Mar 2, 2009
    Location:
    NZ
    #1
    yeah so i found this
    http://web.me.com/smaurice/AppleCod...penGL_ES_05_-_Texture_Mapping_Our_Square.html

    started following that from chapter 1 and got to this one here
    where it says to add the coregraphics framework i get 1 compile error when i'm compiling for iphone 2.2.1 and 122 errors when compiling for iphone 3.0

    if i delete the framework from the project then i still get the 122 compile errors for iphone 3.0

    for 2.2.1 it tells me it can't link to coregraphics framework and that i should use the umbrella applicationservices framework, which comes out red when i try add that and it complains saying it doesn't exist

    for 3.0 it tells me all these syntax errors inside the frameworks taht were there before even though it was working happily with them

    so... how is one meant to use textures in the app when the program permanently doesn't want to compile?
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    You probably added the coregraphics.framework incorrectly. Select the framework in your project and open a Get Info window. The Path Type should say 'relative to current SDK.' If it doesn't, make it so.
     
  3. Chirone thread starter macrumors 6502

    Joined:
    Mar 2, 2009
    Location:
    NZ
    #3
    i did what you said, but it was already on 'relative to current SDK'
     
  4. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #4
    What are some of the errors?

    OK, I downloaded the source project from that web page and it builds with no problem for me. Did you also do that?

    What version of MacOS are you using? What is the Base SDK set for your project?
     
  5. Chirone thread starter macrumors 6502

    Joined:
    Mar 2, 2009
    Location:
    NZ
    #5
    to name a few...
    they all follow things such as
    and
    all complaining about stuff it finds in the frameworks it had no problem with to start with...

    if that makes sense..
     
  6. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #6
    Something is messed up with your project (yes that's the technical term for it :)

    You can start over.

    You can get the project from the web page and open it and yours and compare the project settings line by line to see what the difference is. Probably you are either linking against a library that has a hard-coded path so it's from the wrong SDK or the project settings have a hard-coded path for header search paths. Look at that setting.

    I assume that the AppleCoder-OpenGLES-00 project from the web site works OK for you.
     
  7. Chirone thread starter macrumors 6502

    Joined:
    Mar 2, 2009
    Location:
    NZ
    #7
    yeah, it did work (the project from the site)

    and something was screwed up
    in the build part of my project's info the Framework Search Paths was filled in with two things, but the one from the examples weren't, so i deleted whatever was there and it worked...

    it must have filled itself in when i added the coregraphics framework

    thanks PhoneyDeveloper :)
     
  8. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #8
    Yeah, I think that Xcode adds some things to header search paths or framework search paths when you add a framework, sometimes, and sometimes it's the wrong thing.

    Maybe if you add a framework that is outside the current SDK it adds the framework search path to find that framework. But it's almost always a mistake to add a framework that's outside the current SDK.
     

Share This Page