Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
May 21, 2013
Ok guys, here is my problem and I am totally out of ideas. In 1 department in our plant our prima donna design people all have macs. 3 running OSX 10.8, 1 running 10.6 and 1 legacy machine running 10.4. We have another mac workstation that is our 'server' and it is running 10.4. I use server loosely as it is just the 10.4 OS and nothing else. I am/was using sharepoints to assign permissions. All users login to the 'server' using the same credentials which is an admin. In this department we also have several windows machines that we use in our workflow to create printing plates.

Now the problem. When user A creates a file, they do 1 of 2 things. Either upload it directly to the server, or send it to 1 of our workflow windows stations which converts it to a pdf of high resolution to print which is then moved from the mac workstation onto the server. Either way, end result is the same. File permissions are screwed up. Owner is usually set to unknown and noone has permissions to edit delete or even view the file. I then need go to the 'server' and change the file properties to RWX for anyone to have access to it. This has been an irritant for the last 2 months, but has become more common as time goes by. Now it is almost every file. I have tried everything I know. Need to get this problem corrected ASAP. Have tried FTPing files to the server, and that wont work either. Only manually changing permissions has an effect.

Now for the printer, I guess I used the wrong term. We have a virtual printer mapped on each mac machine. The printer resides on the windows workflow station. It takes a postscript file and converts it to a pdf, outputs the pdf file to a shared folder which is mapped on the mac's desktop. So when they move the file from the printer queue (shared folder) to the mac server permission are jacked. If they take the file from the queue, move to their desktop, then to the server permissions are jacked. If they export directly out of the program they are working with to the desktop, then move to the server, jacked. If they export directly from the program to the server, it is jacked as well.

If I was to move from the machine the queue resides on to the server, permissions are screwed up as well, but diferent users and group. Only thing remaining the same is no permissions.


macrumors newbie
Jan 9, 2013
Its too long - I don't remember how to set permissions with sharepoints.
Look for ACLs instead of posix rights...

A workaround may be setting up a cron job to correct permissions or an appleScript with folder actions...


macrumors 68030
Feb 14, 2007
o the mac really need permissions to be set via share points. I work in a printing enviroment ad need to move files betwen macs PC and Linux. No permissions problems but all the mac log in locally.


macrumors newbie
Jan 25, 2013
As a quick fix and if the machine is in a secure environment, you can set the drive to "Ignore permissions".

See this:

This effectively turns off ALL permissions on the drive. Everyone has R/W access to all the contents.

If this works for you, then in the meantime, I would highly suggest upgrading the machine to at least 10.6 server and use either local groups or Open Directory groups and give the group the appropriate permissions on the sharepoint. 10.6 server was only $29.00 if I remember correctly. Lion and Mountain Lion are even less and all your client should be able to connect with no trouble.

I think this would solve both issues.


Les Kern

macrumors 68040
Apr 26, 2002
ACL's or the cobbled together solution. Best to upgrade to 10.8 for pennies and do it right. A server set up properly would take 10 minutes. Once done, forget about it.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.