Correct Administrator name not valid

Discussion in 'OS X Mavericks (10.9)' started by MacOphileNYC, Dec 29, 2014.

  1. MacOphileNYC macrumors newbie

    Joined:
    Jan 27, 2010
    #1
    I am running Maverick 10.9.5 on a MacBook Pro (2.4 GHz Intel Core i5). I can no-longer make any system updates as my admin name/password are not accepted. I only have one active user and I use the password to log on every time I use the laptop, so I know the password is correct. I have tried the user name listed in Users & Groups which is the current user and is classified as "Standard". The only other user listed is "Guest" which is "Off". I have also tried using the user name at ~/. Users and Groups is locked. I used to be able to make system changes because I was only prompted for the password, the user being supplied automatically (this may have been on an older version of the OS). I have heard of a bug where the administrator name was changed to "root", but that does not work either. Any suggestions? Thanks.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Follow this guide to make a new admin user account then login to that account and give your existing standard account admin privileges. Then go back into your real account and verify you are now admin and delete the new account you made.
     
  3. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #3
    I LOVE this guide! It's like a "secret" that shouldn't be revealed to the public or something! LOL

    I've actually saved those instructions. I can imagine myself needing these instructions some time in the future. Good stuff! :)
     
  4. MacOphileNYC thread starter macrumors newbie

    Joined:
    Jan 27, 2010
    #4
    Thanks for the help Weaselboy. The instructions worked perfectly. Only difference was that the process of creating a new admin account, automatically set my original user back to admin status. Go figure.
     

Share This Page