Correcting Time of Video Assets, Persistency Problem

Discussion in 'Digital Video' started by Ledgem, May 16, 2018.

  1. Ledgem macrumors 68000

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #1
    Hi everyone,

    I have a bit of an odd issue. I posted about it in the digital photography subform a while back, and don't want to duplicate the thread. But here's a summary of what's wrong, and the Final Cut Pro X issue and question follows:

    I take video with an Olympus E-M1 MkII, and noticed that - despite the clock being set correctly - video files are always registered as being taken 10 hours after they really were. For example, if I take a video on 5/16 at 11 AM, Final Cut Pro (and iPhoto, and iMovie) will say it was taken on 5/16 at 9 PM. What's puzzling is that the file creation time, as viewed in Finder, is correct. I checked video settings, time code settings, and so on, but so far I can't figure out why this is happening. (If anyone has encountered something similar, I'd love to hear about it, especially if you were able to fix it.)

    All of Apple's applications have an option to change the date and time (in Final Cut Pro X, it's under Modify > Adjust Content Created Date and Time), and that seems to work nicely enough... but under Final Cut Pro X, if I quit the program and then restart it, the asset is viewed as having its incorrect time again. It's a particularly major problem when using the date/time title, as that will then display incorrect information. I don't believe I had this issue under iMovie; it seems to be unique to Final Cut Pro X, but I'd need to go back and recheck to be certain.

    Any thoughts?

    Addendum: I might have fixed this, at least for Final Cut Pro... I previously had the option checked to also correct the times in the original files. I tried unchecking it just now, and now the readjusted date and time seems to be sticking. So I solved the FCPX question, but it's puzzling what the issue was... does it offer a clue to anyone about why I need to keep making these time adjustments in the first place?
     
  2. joema2 macrumors 68000

    joema2

    Joined:
    Sep 3, 2013
    #2
    The issue with FCPX not updating file-level date/time values is known. I can't remember the details -- maybe it's a permissions thing. I don't recollect this causing a non-persistent time/date value within the FCPX database.

    What disk format are the files are library on? If it's not Mac HFS+ it could behave unpredictably. All media files used by FCPX should always be on HFS+ disk volumes not exFAT or HFS.

    Here's a test: insert a reformatted SD card to the camera, shoot a 5 sec test clip, insert that card to the internal Mac HD, copy the file to your local hard drive (don't import from the card), then import to FCPX from there. See if the behavior changes. Don't use any in-camera GPS tagging, post-tagging, or Olympus utilities or any other processing after shooting and before importing it.

    Normally you format the SD card in camera. If there's any chance you formatted on the Mac, be sure to format the card in the camera.

    There are actually three separate time of day values associated with each file on HFS, exFAT or NTFS: created, last modified, last accessed. Finder will show you all three if you right click the column header while in list view. When troubleshooting this it would be interesting to examine all three time/date values.

    The file-level date/time values are not the only ones. Unlike a simple text file, a video file has other date/time values in the header. These can be seen with a tool like Invisor. I like Invisor because it can display multiple file attributes side-by-side in spreadsheet-like format: https://itunes.apple.com/us/app/invisor-media-file-inspector/id442947586?mt=12

    Once installed, it adds a context menu to Finder. You just right-click on the file>services>analyze with Invisor. To add more files for side-by-side comparison, just drag and drop.

    In the video header displayed by Invisor, I think the created and modified dates are copied from the file system itself, but the encoded and tagged dates are independent and determined by the camera time-of-date clock when the file was originally recorded.

    I don't remember which of these FCPX reads to show a "creation date". However if uses the encoded date within the video header, and if that's wrong, then it's the camera's fault and FCPX is just using what it was given.

    What are these file date/time values (creation, modified, last accessed, *and* encode date/time in video header) -- before import to FCP -- (a) immediately after copying file from SD card to Mac HD and with no other processing, (b) if doing your normal GPS or Olympus processing.

    The fact it's consistently 10 hr off implies some locale-specific offset or UTC conversion is being applied incorrectly.
     

Share This Page