Corrupt USB HDD need some help please

Discussion in 'Mac Accessories' started by hammie14, Mar 18, 2015.

  1. hammie14 macrumors regular

    hammie14

    Joined:
    Mar 18, 2010
    Location:
    London, UK
    #1
    I was setting up a USB HDD as a backup drive and had already transferred data to the HDD. As this was going to be my master backup drive and because there was lots of rubbish on there before I though that I would format the drive. This all was fine. I then transferred some of my data across on to the drive.

    40gb was a secured Knox vault as the information was for work and it has to be secure. The other 7gb was just random backups, pics, software backups etc etc.

    Now here is where the problem starts, I was thinking as this is going to be my main backup drive I thoug I would clean the free space in OS X disk utilities. This was fine and it was running for about 30mins when I knocked the cable on the drive and the cable had been pulled out of the USB on my rMBP.

    I tried to plug it back in and now the drive will not mount. OSX will not mount the drive just says there are problems an it's not able to mount.

    I have tried disk repair in disk utilities but it says it's unable to repair.

    I have some recovery software called disk drill purchased via the App Store and when I load it it shows me the partition with the correct name and says the 47gb has been used. I'm just not able to get to the data.

    I have try to mount it in terminal and it says the drive is damaged and try to use read only, this does not work.

    Currently I have found some info online saying to try and copy the disk with terminal to a DMG file. Currently this is still processing and the DMG file is been made so I'm not sure if this will work.

    Is there any other way I can get the data back, unfortunately the Knox Vault is the only copy I have as the other drive it was on is completely damaged.

    If anyone could assist me in recovering my data I would be so happy.

    Many thanks
    Rob

    In future I will make 2 backups just in case. Hopefully my data is not lost
     
  2. hammie14 thread starter macrumors regular

    hammie14

    Joined:
    Mar 18, 2010
    Location:
    London, UK
    #2
    The DMG file completed all ok

    The command I used was

    Sudo dd bs=512 if=/dev/disk1s2 of=/username/test.dmg

    I now have a DMG file in my home dir but if I try to load it I get , No mountable file system.

    Is there anyway to extract the files?

    The file size used on the drive was 47gb but my DMG file is 499gb (the size of the USB HDD)
     
  3. dyt1983, Mar 18, 2015
    Last edited: Jun 2, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #3
    edit: To remove personally identifying information not relevant to the thread.
     

Share This Page