Corrupt User Account : OS X 10.5.5

Discussion in 'macOS' started by Micrll, Dec 28, 2008.

  1. Micrll macrumors member

    Joined:
    Aug 28, 2006
    #1
    Hello fellow macrumors readers!
    I have a major problem, I was using my macbook (2nd revision black 2ghz, and 2gb ram) on the battery, the battery was running down and the mac went turned off when it ran out of power. Now I assumed it had gone to sleep but apparently it had turned completely off. Now I went to turn it on today, it came on then went black and restarted completely. When it loaded up instead of going to my main account automatically it loaded the user login screen with only the two sub accounts I have for when I am presenting. I loaded one of them up that apparently is now the admin account. I looked in the users folder, my data appears to be there but I do not have sufficient privileges to access it.

    Anyone have any ideas or suggestions on how to fix this. My main account is not showing up under accounts in the user preference pane of system preferences.

    I do have a superduper bootable clone of my hard drive but I don't have the USB cable at this time and it is a older backup (a few months).
     
  2. jonbravo77 macrumors 6502a

    jonbravo77

    Joined:
    Feb 20, 2008
    Location:
    Phoenix, AZ
    #2
    Try inserting your Leopard disk and restart. Hold "C" on startup to get to the install screen. Go to Disk Utility and do a repair permissions. See what that does.
     
  3. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #3
    If repairing your disk doesn't work, you should probably wait till you have access to your clone to make permanent repairs, but you can get to your data now. If you log in with an admin account, you have "superuser" privileges. A bit of Terminal work will make the other account's data accessible.

    Open Terminal and type the following, entering your password when asked:
    cd /Users
    sudo chown -R <admin account> <old account id>

    This changes the owner to the admin account so you can go into the folders and access your files. -R means all subfolders are also changed.
     
  4. Micrll thread starter macrumors member

    Joined:
    Aug 28, 2006
    #4
    Repairing Permissions did not do anything, it fixed some but I still can't see / access the account.
    I think I will wait till I have the clone to get access to the files.

    However, what would be the proper course of action to restore my files when using the clone. I don't want to wipe out everything that has been changed since the last clone.
     
  5. Micrll thread starter macrumors member

    Joined:
    Aug 28, 2006
    #5
    OK, a short followup
    Yes it looks like something hosed the account out, for example, my pictures folder if I go to get info shows that "Everyone" has no access. It also shows the account "(unknown)" has read & write access. I was able to add the account I am currently on as a user of the folder and access my files.

    Additionally when I tried to sudo in to the folder it asked for a password, I entered in all the passwords that it should be and no luck getting that to work.

    Also under user prefrences it shows my old account name as a "group" instead of a actual user.

    This is my plan of attack, I am going over to my friends place to grab the right USB cable. I keep two rotating backup clones on my external, my plan is to clone this drive in its current state to the older of the two backup clones. Then do a full restore from the newer of the backups. Then copy back in my files from the corrupted backup. My only concern is my mail.app preferences and pieces.

    Can anyone help with the migration processes, what should I move and what shouldn't I move?
     
  6. Micrll thread starter macrumors member

    Joined:
    Aug 28, 2006
    #6
    Success!

    Sometimes being a CS major and a geek comes in handy.

    I got it fixed, at least it seams. I am posting what I did incase someone else has the same issue

    I got the USB cable and connected my external drive. Made sure that it was functioning (ran disk verification on it).

    Did a complete clone of the current state of the drive, so I could tinker and if I make things worse have a state to return to.

    I tried to remake my account using the same info username, shortname, password etc. OS X detected the existing home folder and asked if I wanted to use it, I said yes. However then the window went away and the list of registered accounts did not change. After trying a few other small things with no success I got a idea. I made a new account of the same name but with a slightly different short name. Then I right clicked on the account name and went to advanced options. I manually remapped the home directory to my existing one and changed the short name back to the original one and rebooted. No luck.

    It detected the right home folder but apparently I still did not have the proper access priviliges. I then got another idea.

    I rebooted into my working clone from back in september, I went into the advanced account settings and wrote down what my account info was at that time. I rebooted back to the main internal partition, into a secondary account. I then manually edited my account details to match the ones I had written down. A reboot later and I was greeted with my normal desktop wallpaper, icons, dock, even my startup items. It appears that this did the trick. iCal, mail, itunes are all working. I appear to be able to access all my files and such.

    Hopefully this all makes sense and may possibly help a fellow user at some point.

    Also a HUGE shoutout to the makers of SuperDuper, it saved my butt BIGGGGGG time, and I am going to be buying a full licensee so I can use the incremental backups and hopefully avoid this situation from happening again!
     

Share This Page