Corrupted sparseimage file; "Invalid B-Tree Node Size" error... PLEASE HELP?

Discussion in 'macOS' started by ZippyThePinhead, Aug 22, 2006.

  1. ZippyThePinhead macrumors newbie

    Aug 22, 2006
    I have a G4 Sawtooth with an aftermarket WD 80GB drive, running Mac OSX.3.9.

    I shut the machine down this morning and it seemed to shut down normally.

    Later I restarted it and noticed my dock was out of place. At first I thought I'd accidentally logged in to my secondary admin account by mistake (same PW on both accounts), so I logged out and tried again.

    I had not made a mistake... something was wrong with my account. All my desktop files were gone, and my documents folder, which I had been encrypting using FileVault, was empty.

    I did some quick Internet searching to see if I could repair my username.sparseimage file. I hit on this:

    And I followed the steps there. This is when I got the "Invalid B-Tree Node Size" error message.

    Some more Internet searching, and I tried a few different things:

    1) I booted from my OS X.3 (panther) install CD and attempted to repair my HD with Disk Utility. At first, it said there was an error-- sorry to be dim, but I forget exactly what it read-- but then I ran it again and it reported everything was repaired perfectly.

    2) I tried again to repair my username.sparseimage file, but again I got the "Invalid B-Tree Node Size" error message.

    3) I tried to have my sparseimage file decrypted. I put in my password and my G4 took about 30 minutes to decrypt it. There were no error messages during this procedure. I rebooted, but my documents file was still empty and I could not find any of my other files.

    3) I went out and bought DiskWarrior 3.0.3 and ran it. It IDed some errors-- none related to my sparseimage file that I could see-- and repaired my drive some more. I had it replace my directory.

    So far none of this has worked.

    Am I totally out of luck? Does it matter that I had journaling enabled on the disk?

    Any advice/assistance would be appreciated. Thanks in advance...
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    I don't know how to get your data back but I can make two possibly completely unhelpful points.

    1. Continue repairing the disk until no changes are made. In other words, if it fixes something the first time, but not the second time, run it a third time all the same.
    2. Avoid FileVault. It is buggy and incomplete IMO. Sorry, I know this doesn't help and it seems you may have found out the hard way but hopefully someone far smarter than myself can be more helpful in the meantime.


Share This Page