Corsair Memory

Discussion in 'MacBook' started by staylorp, Aug 8, 2013.

  1. staylorp macrumors newbie

    Joined:
    Aug 8, 2013
    #1
    Hey guys, I'm new here, just posted in the Unibody thread too!

    Has anybody else had issues with Corsair memory? I get 3 beeps when I try to boot with a new batch and I keep reading others with a similar problem. 3 beeps usually means that the memory is dead, but the memory has been tested with Memtest on another machine and there is nothing wrong with it.

    The memory I purchased specifically was 8GB (2 x 4GB) DDR3, 1066mhz.

    Going to return it for another brand either way I think, but is this known to be a common problem with Corsair specifically? If so, has anybody worked out a way to 'fix' it?
     
  2. Jaben3421 macrumors regular

    Joined:
    Sep 18, 2011
    Location:
    CA
    #2
    When I bought 8GB of RAM for my MacBook, it worked fine on the first try. But the other identical set for my wife's MacBook did the 3 beeps, and had to be returned. The next set and it was fine. So I guess it just depends on the kit you get. Just a luck game. Lesson of RAM shopping, make sure you always buy from somewhere it can be returned.
     
  3. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #3
    Sounds Like you have dodgy ram. I myself have not had a good experience with corsair Memory and have run into the same problem where my Macbook refuses to boot and returns 3 beeps. Checked that the ram was seated properly and it was, so ended up exchanging the corsair kit for a kingston 2x 4gb kit and have never had a problem since.
     

Share This Page