Could Bitesms ever support google voice texing?

Discussion in 'Jailbreaks and iOS Hacks' started by bbplayer5, Nov 19, 2010.

  1. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #1
    Seems like I would never need an unlimited text plan if this were the case. Anyone know if its in the works or possible?
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    possible, yes! (APIs are public)... On the work....haven't seen anything on the BiteSMS forums
     
  3. Sixth Street macrumors member

    Joined:
    Oct 7, 2007
    #3
  4. DeuceDeuce macrumors 6502a

    DeuceDeuce

    Joined:
    Aug 8, 2007
    Location:
    San Dimas, CA
    #4
    Exactly, worth every penny!
     
  5. bbplayer5 thread starter macrumors 68030

    Joined:
    Apr 13, 2007
  6. mikeheenan macrumors 6502

    Joined:
    Aug 8, 2007
    #6
    So does this mean with this add on, when someone receives a text it'll show up as your regular phone number and you won't get charged for the text message(s)?
     
  7. chris-o macrumors newbie

    Joined:
    Aug 20, 2010
  8. robotphood macrumors 6502a

    Joined:
    Jun 25, 2010
    #8
    Oh my god. I'm so glad I stumbled across this thread. Been using textnow with GV SMS for half a year now. Always wanted to use BiteSMS but saving 20$ a month was too much.
     
  9. mikeheenan macrumors 6502

    Joined:
    Aug 8, 2007
    #9
    I downloaded the SMS GV extension, but how do you configure it with bitesms to get it to work? On the bitesms settings menu, it asks you if you want to send the message through your mobile carrier or through bitesms.
     
  10. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #10
    Do you have SMS GV Extensions set to 'Enable Send'?

    Have you tried using biteSMS?

    Hint: No changes are needed in biteSMS.
     
  11. mikeheenan macrumors 6502

    Joined:
    Aug 8, 2007
    #11
    Yes, i made sure enable send is selected and also the GV icon in sbsettings is selected as well. I tried using bitesms to send a text but the red exclamation point error icon pops up.
     
  12. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #12
    I have biteSMS set to send via carrier and the same settings for SMS GV - works fine except the recipient sees my GV phone number versus my cell number which they are used to, but that's to be expected. When they reply, I see +1 (area code) xxx-xxxx which more often than not is not what is in my Contacts so I see a number instead of their name. Since I am not a real heavy texter, I may not stay with this.
     
  13. robotphood macrumors 6502a

    Joined:
    Jun 25, 2010
    #13
    So when you reply to a person's text it is their number but since it has a +1 it doesn't show up as their name?
     
  14. mikeheenan macrumors 6502

    Joined:
    Aug 8, 2007
    #14
    After testing with a few friends, it appears I can send texts via GV# but not receive in biteSMS.
     
  15. Los macrumors regular

    Joined:
    Jul 5, 2010
    #15
    Probably a bug. I sometimes get this with the extension, but it's very rare. What I did use to get constantly though is getting texts from this "0000" number on some of my contacts. I e-mailed the dev and he told me it' a bug he's working on and the reason it happens is if you have special characters in your contact's name like Quotation Marks or the little star (*) symbol. So remove those for the time being and all shall be fine. :cool:

    Well first of, did you pay for it and did you get your license? If you have, it make take a while for it to activate. So just make sure that the license is set to "bought" instead of "trial" that way you can receive text messages.

    The next thing you need to do is have the Google Voice app installed in your phone with push notifications turned on. This is essential for the Extension to be able to grab the Google Voice text notifications and then forward them to the Native SMS App.
     
  16. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #16
    Correct.
     
  17. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #17
    Nope, I do not have special characters in the Contact's name. The problem is I did not have the +1 in the Contacts entry since it's not needed to call them. So, there's no match when they reply.
     
  18. Los macrumors regular

    Joined:
    Jul 5, 2010
    #18
    I don't have my contacts numbers like that at all, yet I receive the text messages just fine. :eek:

    Why not contact the Dev? I'm sure he'll help you out. :)
     
  19. mikeheenan macrumors 6502

    Joined:
    Aug 8, 2007
    #19

    This is what I didn't do.... and it solved the problem, thanks a bunch!
     
  20. robotphood macrumors 6502a

    Joined:
    Jun 25, 2010
    #20

    I receive text messages fine too and none of my contact's numbers have +1 in them. Definitely contact the Dev.
     

Share This Page