Could Comcast be throttling my AppleTV's connection?

Discussion in 'Apple TV and Home Theater' started by sandman42, Apr 18, 2009.

  1. sandman42 macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #1
    I am continuously having problems downloading movie rentals (or purchases) on my :apple:TV, even though it's obviously connected to the internet and can access the ITMS for everything else.

    Lately when I try to download a movie all goes well until the actual download is supposed to start, then it hangs at 0%, and when I look in the 'Downloads' menu (under 'Settings'), the movie is listed but says 'waiting to download'. If I try to resume the download it tries for a second, then shows 'waiting to download' again.

    I know that my :apple:TV is connecting to the internet ok because I have no problem accessing any of the other online content, including the entire ITMS catalog, including previews, etc. I can watch ITMS movie trailers. Also YouTube works fine.

    Most of the time if I screw around restarting my :apple:TV, my Time Capsule, and/or my (Comcast) cable modem it eventually wakes up and can get the download going, but it's a pain in the @55 to have to do that every time we want to rent a movie.

    Has anyone else had a similar problem? Does it seem likely that it could be my ISP's fault, or could it be a problem with the ITMS? It's been going on for a few weeks now.
     
  2. FF_productions macrumors 68030

    FF_productions

    Joined:
    Apr 16, 2005
    Location:
    Mt. Prospect, Illinois
    #2
    I have comcast, have not dealt with that kind of throttling, theoretically, you should have a speed boost. Unless you download over 250 gigs, there is no reason for a slowdown.

    So, my first question would have to be, how is your Apple TV connected to the net, wireless/wired? I know you said that youtube and the others worked, but a movie is a tad bit bigger. Just asking the basic questions before we get nitty gritty.
     
  3. sandman42 thread starter macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #3
    Normally my :apple:TV is connected to my network wirelessly, but to see if it made any difference I tried connecting by ethernet - no difference.

    Had the problem again last night. Tried restarting the :apple:TV using the remote, restarting my network (through Airport Utility), restarting my cable modem and my Time Capsule (this time by cycling power), all with no help. Finally I restarted my :apple:TV again, this time by cycling power, and the downloads started coming through. I'm pretty sure I've tried this first on other occasions with no luck, but I can't remember for sure. I'll try it first next time to see if that alone will fix the problem.

    I still think it's pretty weird that the :apple:TV can obviously access the ITMS -- I can browse movies and TV shows and watch all the previews and trailers, etc -- but when I try to rent a movie I can get all the way up to the point where the ITMS asks you to commit to renting the movie, then the connection hangs. Even after it does that, with the download stalled and unable to be restarted, I can still go back and browse and watch previews and trailers and stuff like that. For some reason the only thing that seems to be affected is rentals and purchases.
     
  4. HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #4
    For downloading bigger files like a movie, wired is definitely preferable to wireless in most circumstances. For my own setup, I've found that :apple:TV just works better via a wired connection.

    For your problem, I suggest breaking it into parts and isolating the cause. For example, try buying/renting the movie via itunes itself on your computer. Does the download also hang or does it flow. That would narrow the problem down to either the hardware :)apple:TV), or the ethernet cable running from your router to the :apple:TV, or that jack in your router.

    Eliminate the jack by switching the connections (the one running to your computer that you just proved will download in a more normal way vs. the one you ran to :apple:TV).

    Eliminate the cable the same way (switch them).

    By doing this kind of stuff, you can isolate exactly where the problem lies.

    I had Comcast for a good while and it downloaded movies to the :apple:TV very quickly. But Comcast in one location is not Comcast in another.

    Another option: if you know someone with a DSL or other non-Comcast broadband connection, take your :apple:TV to their house, hook it up and see if it has the same problem there. That fairly easy experiment would eliminate jack, network cable, Comcast service, etc in one shot. If the same problem replicated with this kind of test, you could pretty much blame the :apple:TV and very likely be right. If so, take it to Apple and see if they can help.
     
  5. downinitjr macrumors member

    Joined:
    May 17, 2007
    Location:
    Minnesota
    #5
    Is this a stock TV your running or have you modded, or added additional software (boxee, etc). Have you done so in the past? Have you tried completely restoring the TV, and re-applying the latest update? Try running the Network Test option from the TV menu, I don't know if it will give you any meaningful info, but may help  in the future. Have you tried restarting your cable modem, and hooking the  tv directly to it, skipping your router/time capsule?
     
  6. sandman42 thread starter macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #6
    Thanks for the replies so far. To answer the questions, this is a stock :apple:TV, never been modded in any way. It's running the latest software (2.3.1, and my computers are running iTunes 8.1.1).

    When I first noticed the problem I was connected wirelessly, so I switched to ethernet to see if the wireless connection was at fault. There was no change, so I'm not suspicious of the network connection, either wireless or wired. Currently the :apple:TV is connected to my Time Capsule (dual band) via ethernet, and the TC is connected (wired) to my cable modem.

    This morning I restored the :apple:TV to factory settings (reverted to software 1.0 and erased all content), then updated the software, and set it up with my iTunes all as if it were new. My computer synced it right away, so they're both connected to each other via the network ok.

    I just tried downloading a TV show from the ITMS on the :apple:TV, and the problem still exists. I could browse the store, select the show, click 'buy', and ok the confirmation screen. I had to enter my ITMS password (first transaction since restoring the :apple:TV) and that went normally. The download started, got to 9%, then stalled. In the 'Downloads' menu it says 'waiting to download'. If I try to restart it it tries for a few seconds, then says 'waiting' again.

    This problem started a little while after I got my Time Capsule, so I suppose that could be the problem, but that doesn't make much sense to me. It seems like the problem is isolated to ITMS downloads via the :apple:TV, and nothing else seems to be affected (all other internet functions on the :apple:TV and all computers seem to work fine).

    edit: I have tried running the Network Test from the :apple:TV menu. I immediately get a message "Download of 'test' cannot be completed. Please try again using 'Check for Downloads' in Settings". When I go to the 'Downloads' menu, there's an empty progress bar for 'test' with a message below it that reads 'Download Error (404)'. Even while this is going on, I can still access the ITMS, view previews and trailers, watch stuff on YouTube, etc.
     
  7. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #7
    I have found the the Apple TV if not used for a day or so will lose it's IP from the time capsule. I suggest before buying a movie via the Apple TV renew the network connection and DHCP license. Then use the speed test menu to optimize the throughput. After doing all of that you may find the download to be faster.
     
  8. sandman42 thread starter macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #8
    Hmmm, I don't think this is the problem. The :apple:TV definitely isn't losing its network connection, evidenced by the fact that it can stream, access the ITMS (browse movies/TV shows, view previews & trailers), access YouTube, etc. Everything works fine until I try to download a movie or TV show. The download hangs (starts then stops dead) and won't restart, but even then I can still access all the other network/internet stuff.
     
  9. johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
    #9
    I'm curious how your other large file downloading performance is.

    Not sure if ATV is the only large file application that you're using via your cable connection, but it might be worth testing with say... a ubuntu install iso and see what sort of performance/stability you get.

    A regular bandwidth test wouldn't be accurate because Comcast "speedboosts" short downloads with artificially high transfer rates.

    Previously when I was a Comcast cable customer (FiOS now), I had similar issues to you (not with ATV, but in general) and it turned out that the modem wasn't receiving adequate signal due to a botched outside wiring installation. My BFF is a cable customer and can't download large files without a dl manager because frequently his download will slow to the point that it'll time out.

    Also, one thing you can do to rule out a software/hardware problem on the ATV itself is to bring it to a friend's house and see if it works on his/her network.

    John
     
  10. Robbadore64 macrumors regular

    Joined:
    Jan 7, 2008
    Location:
    Jacksonville, Florida
    #10
    This is just a shot in the dark but, the :apple:TV harddrive isn't full is it? Just saying since the streaming works fine for trailers and YouTube etc. I've always been curious what would happen if my drive completely filled up and I try too purchase a movie.

    I DO suggest what another poster said in that you should try downloading a movie directly to iTunes itself and see how that works. If it downloads fine you can eliminate Comcast. "Eliminate Comcast" sounds kinda nice...

    I would also suggest connecting your cable modem directly to your :apple:TV (then restart everything) and see if perhaps your router is the culprit.
     
  11. pilotError macrumors 68020

    pilotError

    Joined:
    Apr 12, 2006
    Location:
    Long Island
    #11
    One offbeat suggestion... If you do bittorent downloads, they may be hitting you with resets to screw it up and it may affect your ATV downloads. I know my ISP was experimenting with it and it caused me some other problems.
     
  12. Jovian9 macrumors 68000

    Jovian9

    Joined:
    Feb 19, 2003
    Location:
    Planet Zebes
    #12
    I had this issue for awhile as well. Comcast bought out our local/regional cable company and took over about a year ago. Prior to that everything was PERFECT with out internet. After Comcast took over I had to have all new lines installed, a dedicated internet line, a new wireless modem, 2 new cable modems in a year and countless trips from them d/t internet outages.

    My :apple:TV functioned flawlessly under the previous internet company but had increasing trouble as time passed with Comcast. The quality of the movies I would stream on my Xbox 360 via Netflix was awful most of the time. My internet on the computers would sometimes slow to almost dial-up speeds. It has been years since I have downloaded any torrents (and that was prior to Comcast coming here).

    I finally gave up on them and went with a local DSL company. The speed they advertise is 3x slower than Comcasts advertised speed, but performance is probably 5x faster/better. I have no issues with downloading movies on my :apple:TV now or streaming via Netflix on my Xbox 360.

    So I'm not sure if it's a Comcast issue or your set up, but for me dumping Comcast solved a similar issue.
     
  13. jersey10 macrumors regular

    Joined:
    Jan 20, 2004
    #13
    Don't know if it is the same problem, but I have Comcast and have had similar problems with my AppleTV. My problems are limited to high def stuff though - whether it be movies or trailers, my AppleTV takes forever to download and then once I start watching even a high-def trailer, it repeatedly has to pause and then restart the download again. Very frustrating. Non-high def movies and trailers work fine.

    And my AppleTV is wired.
     

Share This Page