Could Lion be causing SSDs to fail?

Discussion in 'MacBook Pro' started by mankymanning, Aug 8, 2011.

  1. mankymanning macrumors regular

    Joined:
    Jul 18, 2008
    #1
    I know this is highly unlikely but I have had an OCZ SOlid 2 SSD fail on me this weekend. It had been fine for 14 months until I moved it over to a new 2011 15" MBP (on Wednesday) and also upgraded to Lion.

    Now obviously it sounds more likely to be the MBP than anything and even more likely to be pure chance.

    However it turns out my friend has the exact same drive bought a few months later and it too has suddenly stopped working this weekend too. He hasn't changed machine but has upgraded to Lion...

    Seems like a large coincidence...I guess I am being paranoid?...
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    OCZ SSDs aren't known for great reliability so what you experienced is pretty normal. They seem to have a fairly high failure rate.
     
  3. egi macrumors newbie

    Joined:
    Aug 2, 2011
    #3
    sadly, OCZ and other sandforce drives fail a lot. I got a cruical m4 after 2 vertexes failed on me.
     
  4. mankymanning thread starter macrumors regular

    Joined:
    Jul 18, 2008
    #4
    Yeah just ordered an M4 myself, arrives tomorrow. Hoping it comes with 0002 firmware preinstalled...otherwise I'll be faffing around trying to find a PC somewhere :(
     
  5. Macjames macrumors 6502a

    Joined:
    Dec 12, 2007
    Location:
    Yorkshire, England
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    You can update the Crucial M4 firmware on a Mac now, I did for my 256GB M4.
     
  6. Macsavvytech macrumors 6502a

    Macsavvytech

    Joined:
    May 25, 2010
    #6
    GOD! I hate this generalization, OWC SSDs are Sandforce SSDs and they don't seam to have high failure rates.
     
  7. mankymanning thread starter macrumors regular

    Joined:
    Jul 18, 2008
    #7
    That's good then, don't suppose you can quickly tell me how ? :)
     
  8. dsio macrumors regular

    Joined:
    Jun 19, 2011
    Location:
    Australia
    #8
    The only real reason why there are so many more reported failures of the OCZ drives to be honest is that they sell far more than OWC or most others for that matter with the possible exception of Intel and Micron (Crucial's parent).

    There is also a staggering amount of user-error, especially people upgrading firmwares for no reason.
     
  9. dsio macrumors regular

    Joined:
    Jun 19, 2011
    Location:
    Australia
    #9
    As a side note, this drive (Solid 2) doesn't even have a SandForce controller in it, but rather an Indilinx.
     
  10. mankymanning thread starter macrumors regular

    Joined:
    Jul 18, 2008
    #10
    It is quite easy for people to get into trouble given the woeful support from OCZ in upgrading firmware for Mac users.
     
  11. Alexjones, Aug 8, 2011
    Last edited: Aug 8, 2011

    Alexjones macrumors 6502

    Joined:
    May 28, 2010
    #11
    Im sticking to my 500 GB 7200rpm drive. Sounds a little too risky to install a SSD.
     
  12. jimbo1mcm macrumors 68000

    Joined:
    Mar 21, 2010
    #12
    Failure Information:OP

    Can you share with us how you determined it has failed and what you did to try and resurrect it?
     
  13. mankymanning thread starter macrumors regular

    Joined:
    Jul 18, 2008
    #13
    Well I wasn't massively scientific but anyway...I was having issues in getting Lion to install from a bootable USB. It would fail "downloading files" which actually means copying install files to the disk. I then tried with Sow Leopard and that failed part way through install too.

    I removed my newly bought Crucial memory and put the original 2x2GB sticks back in and the same result so I surmised RAM wasn't the issue.

    I then removed the SSD and replaced with a 500GB 7200rpm hard drive and the install worked. Finally using a little usb controller for a SATA drive I pulled out of an old drive enclosure, I hooked up the SSD to a different machine via USB. It appeared in Finder just fine but when I tried to copy a large VM file onto it, it just stopped copying after about 1.5GB and failed.

    I had tried erasing the drive in disk utility at various points during all this too.
     

Share This Page