Could not activate cellular data network -- Need Help Expert

Discussion in 'Jailbreaks and iOS Hacks' started by pinay18, Nov 4, 2009.

  1. pinay18 macrumors newbie

    Joined:
    Feb 14, 2008
    #1
    . ok guys i have a 3GS 3.0.1 from att&t (jailbroke and unlock).. and im using it here in the philippines using a local carrier here ..

    i would like to use the 3g internet and probably to tether to my laptop..but whenever i open safari it says "Could not activate cellular data network" etc..

    Cellular data config are properly entered. (apn mms etc.. )

    any fix for this?? or 3g internet can only be used for carrier locked iphones..

    coz i tried calling customer service of the local carrier (Globe Phlippines).. they said 3g internet only works on iphones purchased from them..

    anyone here can help?
     
  2. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #2
    It sounds like the iPhones 3G is not compatible with the 3G that your local carrier uses.

    People that use T-Mobile here in the U.S. can't use T-Mobiles 3G because it isn't compatible with what the iPhones 3G. Does it connect with only edge turned on?
     
  3. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #3
    Just to check, does your contract actually include data? Because if it's minutes and texts only, you would get this.

    Customer services reps don't always give you the right answer, by the way.
     
  4. dread macrumors 6502a

    Joined:
    Jun 16, 2009
    #4
    You will need to find out what the apn, name and password for that carrier to use the internet. Then go into the settings and add the apn settings to your phone.
     
  5. xsecretfiles macrumors 6502

    Joined:
    Aug 1, 2008
    #5
    My sister ran into the same problem while on the at&t network, but because we dropped the iphone plan on her 3gS.

    I got the tethering hack from Cydia to enable the Cellular data settings to display on the iphone. I found out that every time you turn off the iphone, the APN settings defaults to "Iphone"

    Don't know if at&t has a specific proxy for the iphone or whatever, but I was able to switch it back to the wap.cingular settings. but once again those settings disappear once you turn your phone off.

    So make sure you got the right APN settings from your carrier over there and don't turn off your phone lol
     
  6. Carl G35c macrumors 6502

    Joined:
    Aug 14, 2008
    #6
    do you have wifi connection?

    if so go here and choose custom APN for the carrier you want
    http://unlockit.co.nz/
     

Share This Page