"could not activate cellular data network"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iphone4imwaitin, Aug 11, 2010.

  1. iphone4imwaitin macrumors newbie

    Joined:
    Jul 19, 2010
    #1
    after jailbreaking my iphone 4 wıth jailbreak.me i dıdn't have an access to edge or 3g

    i can make calls i can receive calls i can send texts but i can't connect to nternet

    what can ı do

    please help me guys
     
  2. iphone4imwaitin thread starter macrumors newbie

    Joined:
    Jul 19, 2010
    #2
    i receive this message

    could not actıvate cellular data network
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    Do you have SBSettings installed? If yes what does is the Data IP Address? It's near the bottom of the SBSettings pop down menu.
     
  4. iphone4imwaitin thread starter macrumors newbie

    Joined:
    Jul 19, 2010
    #4
  5. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
  6. hedonics macrumors newbie

    Joined:
    Aug 12, 2010
    #6
    Check out this potential fix:

    I too have this problem ! No data. SMS, VM work, however I can't get data across 3G or Edge. I saw this solution below, and it reads like it'll work. I signed up and created an account here, just to pass this information along. I called Apple & Att, it's frustrating that Apple & Att weren't able to present this when going through their process.

    Check this post out, it may work:

    http://forums.macrumors.com/showthread.php?t=946542

    Jun 23, 2010, 12:00 PM #5
    Trejodaniel
    macrumors newbie

    Join Date: Oct 2007

    Solved! I have completely fixed this problem without losing any data (not that i've noticed yet anyway).

    First, let me summarize the problem and briefly address the known solutions. There are multiple issues people are having with the update that -HAVE NOTHING TO DO WITH OUR PROBLEM-. Some people had theirs in airplane mode which apparently gives them a "no sim card" after update. not our problem. Some people can reset settings not our problem.

    Our problem is corrupt APN settings after an upgrade, which can be worked around by installing mobileconfig updates or using the "iPhone Configuration Utility" to temporarily overwrite our APN settings. This is a temp fix that only makes 3g work, no MMS or Visual Voicemail.

    We know that completely restoring the phone and setting it up as new resolves the problem. A lot of us are unable to restore any backups without re-introducing the bug. A lot of us do not want to lose our app data so setting up as new phone is out of the question. Some people have figured out how to set up as new phone and import SMS messages from corrupt backup to new backup. This is a good solution if SMS is the only thing you want…However, some of us want ALL our app data.

    Now for the solution! First, go in to settings on your phone and uninstall any custom profile you may have installed to temporarily fix the APN.

    Now, perform a full backup of your phone (you may want to delete your previous backups or move them out of the directory so that you're not confused with multiple backup files in your backup directory.

    Go to your backup directory ~/Library/Application\ Support/MobileSync/Backup/random-backup-name-here/ and delete this file 8218978e4ab0a48035bb92653145a6be872ea858
    That file contains our corrupted APN information.

    Now RESTORE YOUR PHONE and restore the backup. It will fully restore and then give you an error, ignore the error, it worked. Sync your phone to get all your apps back. 3g works, visual voicemail works, mms works, and i have ALL of my app data! all my contacts, all my photos, all my sms messages! BAM! I RULE!
    If for some reason you don't have that file in your backup directory (i have no idea, maybe they are named differently with different backups) you can find it by entering the backup directory in the terminal and running the following
     

Share This Page